Jump to content
Sign in to follow this  
SusieMaeEinstein

Please HELP! I messed with PATHFINDING and now i can't move anywhere on my sim.

Recommended Posts

Hi, I hope someone can help me right away.  I bought a VKC dog and they said I needed to make some objects Walkable.  Well, I made them ALL walkable and I have figured out how to remove some of it around trees so I can walk around, but now, I'm afraid I've changed something and the only place I can go on my sim is on the border. 

I am getting messages like these and I don't even know what they mean:

[11:06]  [2013/06/15 11:05]  MOVING Off Sim Shrimp Boat (cw): Unable to set prim position or scale: object contributes to the navmesh.
[11:06]  [2013/06/15 11:05]  Woodpecker: llSetLocalRot() does not work on objects that contribute to the navmesh. {RootName Common Kingfisher Deluxe v2.0h, RootPosition { 49.2295, 150.057, 22.7711 }}
[11:06]  [2013/06/15 11:05]  MOVING Off Sim Shrimp Boat (cw): Unable to set prim position or scale: object contributes to the navmesh.
[11:06]  [2013/06/15 11:05]  MOVING Off Sim Shrimp Boat (cw): Unable to set prim position or scale: object contributes to the navmesh.

 

What have I done, please, and how can I fix it?  :-(

 

P.S.  To make myself clearer, I am on a homestead sim with pathfinding enabled and have estate manager rights.  Thanks.

 

Share this post


Link to post
Share on other sites

You've got two sets of land permissions. One is region, one is parcel. I suspect the parcel is owned by someone else and they've restricted access. Try reclaiming it.

Other than that, I can't guess. You could use SimConsole to disable pathfinding, but I'm pretty sure pathfinding isn't your problem here.

http://wiki.secondlife.com/wiki/SimConsole

Try contacting support.

Share this post


Link to post
Share on other sites

Yeah, this is a side-effect of some unfortunate Pathfinding settings.  It's what you get when scripts try to move objects that are set walkable (or "static obstacle", I think).

It all sounds extremely scary, but it just means that the sim isn't letting the script move the thing because its setting makes it part of the Pathfinding navmesh, and fussing about it.

To fine-tune the Pathfinding settings of objects you control in the sim, you may want to use the Pathfinding Linksets Floater.

There's also a sim console command that you can use to set everything to the default "movable obstacle"... that's a little extreme, though, so if you can get back to normalcy with the linksets floater, it might be most prudent. (Also, I'm inordinately lazy and at first cursory glance not finding where it's documented in the wiki. But it's in there somewhere, if it comes to that.)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...