Jump to content
Sign in to follow this  
Marimar Franizzi

Low FPS

Recommended Posts

Hello there .

When decorating my home with  mesh , i recently faced a really annoying issue . Suddenly when rotating my camera around my fps will drop from my regular ~ 50 fps to 7 fps wich is incredibly low .This framerates issue only started few weeks ago , normally was running SL on high with low draw distance on firestorm .Issue will fix by itself if clear cache and relog but comes back after awhile .

Here is my hardware used for SL :

CPU: Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz (3110.52 MHz)
Memory: 8174 MB
OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Graphics Card: GeForce GTX 650 Ti/PCIe/SSE2
Windows Graphics Driver Version: 9.18.0013.1422
OpenGL Version: 4.2.0

I tried many different things to fix this FPS issues :

_Switched to the following different viewers : last Firestorm , last SL Viewer , last Singularity , last Niran . Singularity being the one performing the more stable while Firestorm is sluttering 2 mins after i'm online .

_ Tried different preferences from Low setting to Ultra , with or without vbo or http textures checked . It doesnt matter it will still drop to some poor fps.

_ Adjusted max bandwith and disk cach to low or high numbers , it made nof difference . Actually my disk cache is set 1088 Mb and my max bandwith to 1024 .

_ Removed the mesh models and bought some new ones from different shops but same the framerates will go down and when i tp friends at my place they dont have issues with any of those models .

_ Deleted everything related to Second Life on my hard drives and made a clean install + updated to the lastest Nvidia drivers .

Im running out of ideas how to come back to a stable SL experience , im thinking of some hardware issue but when i monitored heat in speedfan and bios there was nothing worth noticing and i can play recent games with no fps issue .

Is there something i should do to fix this or SL just doesnt like me anymore and i will need to relog every 15 minutes .

Thanks for any help !

Share this post


Link to post
Share on other sites

Just curious ... what is your view distance set too ? It's in your Preferences too ( Graphics tab ).

 

The lower you set it the higher your framerate will get ( but , of course, the less you will see of your surroundings ).

 

Maybe you could also try to get better framerates by switching off lighting & shadows, ambient occlusion and depth of field as well.

 

One more ... you can also set your NVidia-card to specific settings in your Geforce configuration software.

Share this post


Link to post
Share on other sites

One other possibility, albeit remote: Heat. Some CPUs and graphics cards can slow themselves down so as to dissipate less heat when they get too hot. Unlikely, but maybe things have gotten a little dusty in there, or the weather has warmed up, or something, pushing the temps up, and relogging gives it enough time to cool down a bit so it runs at full speed for a while.  I don't know from Windows, but I'm sure there are temp monitoring apps available that will work with your hardware.

Certainly moving the cam causes a lot more textures and geometry to load. I've found that to trigger a temporary drop in framerate, but this seems like something more dramatic than that.

Share this post


Link to post
Share on other sites

I used to get this a lot, I'm not associated with the team, but for the last month or so I've been sitting next to a singularity  developer watching them work, and then using the freshly changed program myself. Yay for being a pre-alpha crash test dummy! xD Recent changes (now in the public accessable alpha version) seem to have removed it, but I am not 100% sure. It was always a weird bug to reproduce inside a mesh building, very noticable, for me my frame rate dropping from 30 to 4. Also nvidia, but on Linux 64 bit.

So, the fix, if it is a fix (and I don't know yet), won't be of much use to you until the Lab do something similar or you move to the latest Singu alpha and are prepared for alpha breakage and the bleeding edge of viewers.

But there are a couple things with the cache size and also the bandwidth settings that may assist you a little.

Firstly, it looks like the Lab throttle our bandwidth. If you exceed what they throttle at you will get some nasty pauses as the servers punish you for asking for too much.

In singu pre-alpha I run 1990 on both bandwidth sliders and it seems work well and blazingly fast, but for other viewers under 2000 and then reducing would be a good guide. 

<tinfoil hat>Mind you it's possible LL do this on purpose to make their spaghetti mess viewer look artifically better and only the LL viewer can increase while all TPVs are capped</tinfoil hat>

Secondly is the cache is shockingly bad. Like really, really bad. Designed by monkeys bad. In fact it's so bad that baby kittens die every time it gets full. That's not even considering the server hamsters, who during their rare naps cry at the extra work they have to do to counter it's badness.

You really don't want it to be very large. So, it could be worthwhile keeping your bandwidth low, turning off shadows (a huge one), and keeping your cache at 512MB

Weirdly, performance increases as you decrease these numbers.

Share this post


Link to post
Share on other sites

Thanks for replying everyone !

Since the last time i posted i did opened my pc , cleaned each cpu and gpu carefully and did format my windows hardrive .

While now computer is running all fresh , sadly after 24 hours the issue returned and i still got really low framerates on Firestorm . Smaller cache size , low settings etc wont really fix the issue , my regular framerates will be better but when rotating camera in some angles it will drops to 5 fps and i need to clear cache to enjoy 15 mins of stable fps .

I will give a try  to singularity again , it was definitively the more stable .

Share this post


Link to post
Share on other sites

I am narrowing in on this bug, but it's annoying.

I have found two causes, but it's a pain witout having a place I can 100% cause it, I wonder if you could tell me if you run your UI resolution > 1.00, as I have found one cause of this mesh slowdown of FPS is a problem redrawing the UI when certain occlusion specifications are met.

You would know quite quickly, setting the UI back 1 while in slowdown mode will see your speed increase fairly fast, within 120 seconds you would be back at full speed. You don't even need to restart.

The other bug is trickier, it's in the occlusion callbacks.

I would have this solved in Singularity quite quickly if I had a place I could see the fault in 100%.  Oh well, it's on my list of things tolook at when it does happen.

Share this post


Link to post
Share on other sites

Hi Sean !

 

Im using Singurality Viewer in windowed mode with a resolution of 1920 * 1018 , this is my screen native resolution .

So far now after many days on Singularity i will still get this slow fps bug but not as bad as with other viewer . One thing i noticed if when i reduce the size of the SL window i wont suffer any fps drops ! Actually im on a 1680 *  1050 resolution window with advanced graphics checked until ambient occlusion .

Share this post


Link to post
Share on other sites

Another thing I found which clears the problem for a short time for me is toggling classic clouds. Turn it off, open preferences, turn it back on and the problem goes for a short time.

I do know it's an issue in how LL use Vertex Buffers on the nVidia with mesh objects, in some cases when the bug is active it really hits OpenGL hard the whole PC crawloing to slowness.

For all this time I've been running singularity in debug mode working closely with a developer as we try and track it down together. I get about 2 per 8 hour play time on average.

It's hard to find the cause though, what it does highlight is workarounds. However these workarounds are temporary and the problem returns faster and faster each time until you are forced to log out.

 

I am chasing a suspect that it's when a panel (like the invetory window) is open and you move the camera. This is only a felling in my mind though, I'm not 100% sure. (( Hmms and considers turning on Inu's recent opaque windows patch ))

 

Anyway, I am not giving up as I hate this bug, and the two work arounds I have found so far; altering the UI size on the general tab and also toggling classic clouds for me at least remove the problem for a little while.

It's likely that these are resetting the Vertex Buffers and thus remove the problem for a little.

I need to pounce Siana one day and ask their thoughts.

 

Edit: this code of the Linden's is fragile, recursive horror. We took a break from this problem last night to track down the llwindow:makeActive() assert bug (we call it the seagull bug) that makes us assert (crash with a continue question) every single teleport home. >.<

But we have found an object in world to trigger it that we now have in our own region.... Hmm I digress. The Lindens responsible for the graphics drawing have used black magic and obviously sacrificed a prim baby to cobble this chunk of horror of vertex buffers that causes our FPS lag together.

Share this post


Link to post
Share on other sites

TL;DR: Lower Viewer Texture Memory Buffer under Graphics, Hardware Settings to <288MB.

 

I know this is an old thread, but (for me at least) it's still a debilitating issue. I noticed it when my friends got mesh houses and my framerate dropped well below 1 FPS and made my entire computer slow. I don't have the best rig but a Haswell i3 and a GTX 750 should have no problem running SL! Yet for some reason if these houses are rendered, I'll drop to sub 1 FPS in less than 10 minutes!

Anyways, I think I have found a legitimate fix! Whilst checking around in the settings, I thought I'd mess around with the Viewer Texture Memory Buffer under Graphics, Hardware Settings. Lowering it to the minimum worked, and I played in both houses for several hours, albeit with horri-bad texture quality. Interestingly enough, SL wasn't using all of the video card memory either (as mesured by Process Explorer)! Curious, I played around with the Texture Buffer Memory slider until I got the GPU memory usage hovering around 900 MB (out of 1GB) and have not had any problems yet! Going higher caused sub 1 FPS again. Sometimes textures can be a bit blurry but it's better than unusuable framerate dips. My magic number is about 288 MB. I plan to upgrade to a 750ti with 2 gigs of memory sometime, if I do I'll max the buffer memory again and make another post here with the results. I hope this helps someone!

I'm using the latest version of Firestorm by the way. I feel like I have my hands tied with any other browser! >.<

Share this post


Link to post
Share on other sites

Sorry to revive a kinda old topic but I am having the same issues... heres my pc specs:

intel core i5-2500 cpu @ 3.3ghz

8 gb ram

windows 8 64 bit

graphics: nvidia geforce gtx 650 Ti

 

I have a new house, decorating with mesh furniture, mesh landscaping. pretty much everything in the house is mesh, including the house. my fps doesnt drop nearly as low as the OP but it drops significantly enough to tick me off. Ive ransacked my house looking for high-poly items and removing them... It may have helped only very little, but not enough. However, lowering the viewer texture memory buffer setting does reduce the fps lag (who knows why??), but it ticks me off in another way, which is textures keep loading over and over when i am moving my view around and it just looks like crap! So its either deal with crappy textures, or deal with crappy fps. cant have best of both worlds i suppose.

 

I have been playing with maybe another solution ... if someone else is having this problem perhaps they can see if it helps them any. On my computer, im always running second life graphics on the 'high' notch. I lowered the notch down one, the notch before 'high' which all it really does is just change the water reflection down to 'all static objects.' I keep the LOD at 4 though. I noticed a reduce in fps lag, for now. This is with the texture memory buffer setting on max as well. Maybe its because i am surrounded by water at my house, i dont know really. I do want to add more memory to my computer (at least to 16 gb) but i am really unsure whether it will actually help the problem or not.

Share this post


Link to post
Share on other sites


vixtris wrote:

Sorry to revive a kinda old topic but I am having the same issues... heres my pc specs:

intel core i5-2500 cpu @ 3.3ghz

8 gb ram

windows 8 64 bit

graphics: nvidia geforce gtx 650 Ti

 

I have a new house, decorating with mesh furniture, mesh landscaping. pretty much everything in the house is mesh, including the house. my fps doesnt drop nearly as low as the OP but it drops significantly enough to tick me off. Ive ransacked my house looking for high-poly items and removing them... It may have helped only very little, but not enough. However, lowering the viewer texture memory buffer setting does reduce the fps lag (who knows why??), but it ticks me off in another way, which is textures keep loading over and over when i am moving my view around and it just looks like crap! So its either deal with crappy textures, or deal with crappy fps. cant have best of both worlds i suppose.

 

I have been playing with maybe another solution ... if someone else is having this problem perhaps they can see if it helps them any. On my computer, im always running second life graphics on the 'high' notch. I lowered the notch down one, the notch before 'high' which all it really does is just change the water reflection down to 'all static objects.' I keep the LOD at 4 though. I noticed a reduce in fps lag, for now. This is with the texture memory buffer setting on max as well. Maybe its because i am surrounded by water at my house, i dont know really. I do want to add more memory to my computer (at least to 16 gb) but i am really unsure whether it will actually help the problem or not.

Reduce your LOD to the minimum you can run without having issues with bad sculpts and mesh. That's what's chewing up your video memory. Ideally you should be able to run it at 2; mine is at 2.5 because of a few specific problem items I have. If you have items that give you serious problems at a LOD of 2.5 you should think about replacing them.

Share this post


Link to post
Share on other sites


Theresa Tennyson wrote:

Reduce your LOD to the minimum you can run without having issues with bad sculpts and mesh. That's what's chewing up your video memory. Ideally you should be able to run it at 2; mine is at 2.5 because of a few specific problem items I have. If you have items that give you serious problems at a LOD of 2.5 you should think about replacing them.


Sorry I do not know what you mean. There is no problem with LOD. The LOD graphic option, whether on 2 or 4, makes no difference in the lag - the only reason i mentioned it was because objects distort if its on a low setting - most people like to have it on 4.

Share this post


Link to post
Share on other sites

I've never heard that having LOD set above 2 or 2.5 causes video memory issues ... do you have documentation for that? I run with LOD set at 4 all the time (LL and Firestorm viewers) using a GTX 560 Ti with 1GB VRAM and I experience no memory issues. when I run with LOD set lower lots of things don't rez properly.

Share this post


Link to post
Share on other sites


Cincia Singh wrote:

I've never heard that having LOD set above 2 or 2.5 causes video memory issues ... do you have documentation for that? I run with LOD set at 4 all the time (LL and Firestorm viewers) using a GTX 560 Ti with 1GB VRAM and I experience no memory issues. when I run with LOD set lower lots of things don't rez properly.

Elevating your LOD causes everything to hold a higher level of detail from a longer distance and that uses memory - so much that it can make your viewer freeze when it has to dump cache. If you don't have memory issues you don't have memory issues. However, people who DO have memory issues can be helped by turning their LOD down. Personally I keep my draw distance fairly high because I use a lot of vehicles and want extended sight distance and can live with minor detail pumping in comparatively distant objects. Things that fall apart with lower LOD's are a symptom of sloppy building. They can be unavoidable but I see no reason to encourage bad practices in general.

Share this post


Link to post
Share on other sites

Do you have, or can you point to, documentation of this? I'm not trying to be snarky, I just don't accept explanations without documentation because that's how misinformation gets spread and becomes accepted truth regardless of a lack of basis in fact.

Share this post


Link to post
Share on other sites


Cincia Singh wrote:

Do you have, or can you point to, documentation of this? I'm not trying to be snarky, I just don't accept explanations without documentation because that's how misinformation gets spread and becomes accepted truth regardless of a lack of basis in fact.

You can use the texture console and memory use statistics in the "Develop" menu. I should also point out that the LL viewer (the only viewer written by the people who wrote the basic graphics engine) doesn't allow you to set a LOD over 2 in preferences. Also, when the "Set your LOD to at least 4" advice originated there were only sculpts used. Since 2011 this setting also affects mesh, which changed the playing field radically.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...