Jump to content
Sign in to follow this  
Mitchell Indigo

This is Getting Frustrating!!

Recommended Posts

Ah, thanks. That's much more recent than the last time I'd registered that any specific cause was identified for vehicle sim-crossing problems, which was back when Pathfinding was rolling out.

(Speaking of Pathfinding, and totally off-topic: check sim statistics for Pathfinding on a sim with the release just rolled today. I even see Spare Time on a sim that was always bogged down before.)

Share this post


Link to post
Share on other sites

It's the Lindens saying, thank you for your payment.  This texture Rebaking thing needed to be tested more. I'm losing sales as products aren't rezzing.  Yes it's frustrating for all of us.  Hey Labs, fix it please!

Share this post


Link to post
Share on other sites


Qie Niangao wrote:

Do we think the vehicle sim-crossing problems were associated with the interestlist changes?

It could be; I honestly don't know. Over the past seven years that I've been in SL, the intervals during which vehicles could reliably cross sim borders have been so brief that I've rarely noticed.

There were region crossing issues resulting from interest list changes, vis:

 

As originally deployed, the interest list code (as you know) only updated the viewer with information relating to objects within the camera’s field-of-view. When crossing a region, the camera position was extrapolated first, with any vehicle the avatar was attached to being created "behind" the camera in the region just entered. Because of this, the interest list code considered the vehicle to be outside the camera's field-of-view updates for the vehicle ceased - hence problems with vehicles ending-up "snagged" at crossings.

HOWEVER - this particular issue was fixed in week 12

Whether the interest list code is in any way responsible for further vehicle crossings is debatable. I've no idea one way or the other (which isn't actually saying a lot, I know! :)).

Share this post


Link to post
Share on other sites

It looks like the bug might be cured in the 3.5.2 (275653) beta build. At least, I can make it happen at will in viewer-release today, but am not seeing it all on that new build. The patch is tiny too.

Share this post


Link to post
Share on other sites

I keep an eye on vehicle crossings. Lest week was better than this week. There were some big problems that coincided with Pathfinding, which needed a new Physics engine. Threaded code, introduced this year, did improve things. The Second Life server is very complicated, and I infer from some of the things said by Monty Linden about shifting communications to HTTP froim UDP, that there is a bad case of spaghetti code.

Even without region crossing, vehicle function get worse with the arrival of Pathfinding.

I cannot recall seeing any significant use of Pathfinding, beyond the demo regions which the Lindens set up, with that jungle and river. If people aren't using it, was it worth doing?

But complicated mesh objects, and heavy scripting, also make a difference. Some vehicle builders seem to know what they're doing. Some seem to have a complicated model and drop in a large set of third-party scripts, and send up with something sensitve to problems.

There is not one big problem with vehicles, but it isn't hard, using the same vehicle week after week, to see differences which coincide with server changes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...