Jump to content
Sign in to follow this  
Maestro Linden

Deploys for the week of 2013-04-22

Recommended Posts

Second Life Server (main channel)

The main channel is getting the server maintenance project which was on all three RC channels last week.

http://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Server/13#13.04.12.273874

Scheduled Tuesday 2013-04-23 05:00-12:00 PDT

 

Second Life RC BlueSteel and Second Life RC LeTigre:

BlueSteel and LeTigre are on a new project which brings preliminary server-side support for experience permissions.

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_BlueSteel/13#13.04.19.274370

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_LeTigre/13#13.04.19.274370

Scheduled Wednesday 2013-04-24 07:00-11:00 PDT

 

Second Life RC Magnum:

Magnum is on a new server maintenance project.  This update brings some new minor features to LSL, and fixes some crash modes

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Magnum/13#13.04.19.274352

Scheduled Wednesday 2013-04-24 07:00-11:00 PDT

 

We will be monitoring this thread as the code gets released, so feel free to note any observations you have about the server updates.  If you have a specific bug you'd like to report, please file a Jira

Share this post


Link to post
Share on other sites

Hi Louise,

The chatlag problem (BUG-2406) isn't something that LL can fix by doing something technical.
Of course LL could pick up the phone, or send a mail to the faulty relay station. :)

I've tried to talk to my provider, but they can't be bothered. Computer says no ...

=======

Hi Maestro,

My compliments on script performance!
I don't think I've ever seen Egglebury run so smooth. :D

Share this post


Link to post
Share on other sites

Hi Lydia, I don't have any news about the 'missing prims' issue.  Since it's a viewer bug, the fix would likely come from a viewer release.


Louise: No, there are no changes which should affect latency much.

Share this post


Link to post
Share on other sites

Many thanks as well, Maestro, for fixing the link for the posting of this weeks updates ;)  The only thing I've noticed on my estate with yesterdays deploy  is that some of the servers (SL Server (main channel) may be having issues communicating with each other once again.  This happens when flying from region to another.  Until this last deploy they were almost flawless for the last few weeks.. I've gotten spoiled ..lol.. Thanks again. 

Share this post


Link to post
Share on other sites


Maestro Linden wrote:

Second Life RC BlueSteel and 
Second Life RC LeTigre
:

BlueSteel and LeTigre are on a new project which brings preliminary server-side support for experience permissions.

Scheduled Wednesday
 2013-04-24 07:00-11:00 PDT

I *thought* the experience permissions had to do with giving us the ability to create games like Linden Realms with instant teleport of avatars without asking permissions. Remember this got implemented months ago and then rolled back because of some unintended uses by griefers?

When I read the release notes it only talks about the updates to improve and simplify animation overrides. I agree this is equally exciting and I am looking forward to it as well.

 

So, am I confused on which project is which or did I not read something?

If I'm confused, what is the enhanced game tools project actually called?

Share this post


Link to post
Share on other sites

Not much yet, AFAIK, but I understood from Simon yesterday that they hope to have some sort of docs drafted soon.

My vague recollection of this is that there's to be some sort of token (an "Experience Key" apparently) that scripts can pass among themselves, corresponding to a user-granted permission. I have no idea what the backend is for verifying / authenticating these tokens, nor their duration (a login session, I kinda hope, and/or until somehow revoked). IIRC, their extent is not to be limited to a single sim (important for llTeleportAgent, for sure, and presumably present in Linden Realms), so that suggests something about how the backend might work.

Share this post


Link to post
Share on other sites


LouiseDeBlois wrote:

Will this be fixing the intense chat delays and prim movement for other regions outside of the US? As many people are getting this issue.

I`m having this issue now aswell since the new rollout

Local chat lag

Long region crossings

Inventory unresposive

Doing anything on the land feels like rubber banding, prims change back to old position/size/slow rez/changing clothes takes for ever

My ao starts doing weird things like starting to dance while it`s in normal mode, typing animation while i`m not even typing

It`s not lag as everything else is instant, IM go trough instantly, movement is instant, everything rezzes instantly, ping time stayed the same/etc etc etc

 

What has changed?

This all started to happen right after the rolling restart to 13.04.12.273874

 

*edit*

Maybe it has nothing to do with the new server code, but other changes to the network as there was also unscheduled maintenance with the failing inventory going on and some one changed abit to much and it`s just happening at the same time along the release that it`s blamed

This is worse then some missing prims, rather have that feature then a non responsive world i can hardly do anything in

http://community.secondlife.com/t5/Second-Life-Viewer-Basic-Mode/In-game-chat-delay-excluding-IM-S/m-p/1981071#M1199

Share this post


Link to post
Share on other sites

We know what Experience Permissions started out to be: http://blog.nalates.net/2012/05/30/sl-news-week-22/ -- that includes a Linden made video.

There was a problem:  Greifer Monday which made for a chaotic day in SL.

That caused a delay as the concept was rethought and some new means of accomplishing similar things was coded. This seems to have grown into a project named Advanced Creator Tools. We expect some special registration requirements to use the tools.

Share this post


Link to post
Share on other sites

Curious Hazelnut wrote:

I *thought* the experience permissions had to do with giving us the ability to create games like Linden Realms with instant teleport of avatars without asking permissions. Remember this got implemented months ago and then rolled back because of some unintended uses by griefers?

If I'm confused, what is the enhanced game tools project actually called?

The experience permissions were never released for us on the main grid.

What actually happened was that the llTeleportAgent* functions were added to the public LSL compilers on an RC channel, just with traditional permissions, and someone forgot that an unrestricted version of the function was already running on the whole grid to support the Realms portals that used to be scattered around sandboxes and infohubs.

(It didn't really matter if the functions had proper permissions before then, because the public didn't have the ability to compile those functions into a script.)

So, those were temporarily disabled until the whole grid had permission checks in place. At the same time, they restricted the uses of those functions even with properly granted traitional permissions.

Share this post


Link to post
Share on other sites

Alicia

Many folk on the Eastern side of the Atlantic are seeing these issues, and while some of it may be internet (US side for sure) related, there are some very strange script communications happening, and that is, I think down to the server software changes.

I know Linden Lab test these changes, but sometimes I wonder what they test them on!:smileyfrustrated:

Share this post


Link to post
Share on other sites

If you guys are having it also, then... ;)
Weird script things, i just started dancing for no reason, again :matte-motes-sour:

Your blog is hilarious, had a good laugh reading some of them :D

Share this post


Link to post
Share on other sites

after the last update on my sims:

- some scripts uncheck the SLS mono, and not running, i have to chekc the mono again, then they run

- scripts are much slower, example : get info with llGetRegionSay

- some scripts (HUD) i have to recompile before they can run again as expected

Share this post


Link to post
Share on other sites

I live on a Magnum sim and when I logged in tonight after the roll my KittyCats breedable cat was giving a script error stating that it couldn't find the "KittyCats - Sleep" script, even though it showed up when I edited my cat. Given my cat's proclivities I suspect this script was running when the server software was rolled. She seems to be behaving normally now after I took her into my inventory and re-rezzed her.

Share this post


Link to post
Share on other sites


Cerise Sorbet wrote:


Curious Hazelnut wrote:

I *thought* the experience permissions had to do with giving us the ability to create games like Linden Realms with instant teleport of avatars without asking permissions. Remember this got implemented months ago and then rolled back because of some unintended uses by griefers?

If I'm confused, what is the enhanced game tools project actually called?

The experience permissions were never released for us on the main grid.

What actually happened was that the llTeleportAgent* functions were added to the public LSL compilers on an RC channel, just with traditional permissions, and someone forgot that an unrestricted version of the function was already running on the whole grid to support the Realms portals that used to be scattered around sandboxes and infohubs.

(It didn't really matter if the functions had proper permissions before then, because the public didn't have the ability to compile those functions into a script.)

So, those were temporarily disabled until the whole grid had permission checks in place.
At the same time, they restricted the uses of those functions even with properly granted traitional permissions.

Thanks for the memory refresh, Cerise. I'd forgotten all that history. The part I highlighted above, however, was something that I never understood, and still don't. That's one reason I'm so curious about what XP is really going to deliver now. (That, and the extreme secrecy that's surrounded development.)

Share this post


Link to post
Share on other sites

Here is a little info on a connection between the missing prim issue and some of the problems with scripts people have been reporting.

I have a bot that wears a HUD, and on a daily basis TP's to a lot of sims. About the time the interest list project was first introduced, script errors started occurring on a once-in-a-great-while basis. The problem turns out to be related to the missing prim issue.

Every once in a great while, one prim in the HUD the bot wears fails to rez after a teleport (it is always the same prim). That prim has 1 script in it, and when the problem occurs this mono error is displayed:

[2013/04/25 06:21]  Crosshairs: Crosshairs [script:Ban Line HUD Crosshairs Script] Script run-time error
[2013/04/25 06:21]  Crosshairs: System.NullReferenceException: Object reference not set to an instance of an object
   at LindenLab.SecondLife.UThread.UThread.Run () [0x00000] in <filename unknown>:0
   at LindenLab.SecondLife.Script.Run (ScriptEvent evt) [0x00000] in <filename unknown>:0

At that point the HUD will not function again until I log the bot in with a normal viewer in order to reset the scripts in the HUD.

A similar type of problem could have been what happened to Theresa's cat.

If there is a JIRA that is relevant to this and someone can get this info into it, please do so.

ETA: It seems to me that if the missing prim issue was strictly a viewer-related bug that it couldn't crash server side scripts. OTOH, since this is a HUD maybe this bug is completely unrelated to the missing prim issue. But still something to think about.

Share this post


Link to post
Share on other sites

One thing I have increasingly noticed over the last month is the number of avatars that reside at 0,0,0; this has been noticed especially on Kama Sutra (sim6225).  Interestingly enough these avatars often show correctly (or vice versa) on another computer running an Alt from exactly the same UK location. Both computer specs are very similar, same internet connection, both running the same firestorm viewer version, same sim, so it appears that some data is getting garbled leaving the sim.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...