Jump to content

Using flexy to make one prim phantom


You are about to reply to a thread that has been inactive for 3603 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Short version: flexible (but stiff) prim in a build sometimes displays at a slight angle, is there a way to prevent this?

Long version:

A long time ago I learned this trick here: If you want to make one prim in a build phantom without making the rest of the build phantom, you can do that by marking the prim flexible but setting the parameters so it was actually very stiff. For example, make the water prim on a hot tub flexible so if people walk over it, they sink through the water but stop when their feet hit the non-phantom bottom.

I hear rumors that there is a new official way to do this now, but I'm building things that I want to work on Open Simulator so I'm still using the old tried and true trick.

But I recently ran into a problem, which is probably a problem in the viewer. (I like Firestorm these days).

I built a BIG pool (using megaprims) that is 128m long on the longest side. It has sandy-textured beach prims around it, a sandy textured bottom and water made from a 128x64m prim with a transparent water texture on it. This water prim is marked flexy so if people walk on it they sink to the bottom. Most of the time this works fine. (My scripted vehicles know to float on the water prim).

But I was swimming in my pool recently and noticed that at one end the water was higher than at the other end. I checked it with the build menu and it was not rotated, and when I closed the build menu the prim suddenly rotated back to where it belonged! But I looked away and back again later and the prim tilted again. If I change it to non-flexy it also goes back to the zero rotation.

Has anyone else had this problem? Is it just a Firestorm problem or do other viewers do this? Is there a workaround for it? (I've tried changing the flexy parameters with no luck so far).

 

Link to comment
Share on other sites

I've never tried making a prim that big flexi, so I can only guess that you're seeing something like a roundoff error in how your GPU interprets "very stiff." An angle of 90.00 degrees might not be the same as one of 90.00000 degrees --- unnoticeable unless you are working with a supersized prim.  So long as the prim isn't the root of its linkset, though, try setting its physics type (in the features tab) to "None".  That should make it phantom without having to use the flexi trick.

Link to comment
Share on other sites

If your desired prim isnt root (root must be solid) simply edit linked,select only that prim,go to features tab (where flexy is) and on prim physics type change to none and you get phantom prim in linkset without making others in linkset phantom.No need to make it flexy at all,problem solved.

Link to comment
Share on other sites

When you do that, though, it's normally a good idea to set the whole linkset to Convex Hull first.  This is because the physics cost (and thus the land impact) of some prims -- particularly cut or tortured toruses -- can go sky-high if they're left as prims when Mesh Accounting is used to determine the LI, which it is, as soon as any prim in the linset is set to None or Convex Hull.   

If the LI is unacceptably high, then it may be necessary to go through the child prims one by one, setting any cut or tortured ones to none, too.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3603 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...