Jump to content

HTTP Textures


You are about to reply to a thread that has been inactive for 3591 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Did a clean install of Firestorm and am unable to use HTTP Textures - bumped up my cache about half way hoping that would help. If HTTP Textures  is turned on - i freeze and lose my connection.   My network appears to be fine - graphics card updated.  Is this detrimental - or just a live with situation.  I've had this problem with SL Viewer also and Firestorm - not a new problem but just got to thinking about it.  I also set the card to use the Geoforce -

Anyone have any ideas?

System Info Below

Firestorm 4.3.1 (31155) Dec  2 2012 00:45:37 (Firestorm-Release) with Havok support
Release Notes

You are at 193,446.0, 319,141.0, 194.8 in Misali located at sim9864.agni.lindenlab.com (216.82.46.6:13025)
Second Life Server 13.02.21.270686
Release Notes

CPU: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz (3392.33 MHz)
Memory: 8110 MB
OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 570/PCIe/SSE2

Windows Graphics Driver Version: 9.18.0013.1407
OpenGL Version: 4.2.0

RestrainedLove API: (disabled)
libcurl Version: libcurl/7.21.1 OpenSSL/1.0.0d zlib/1.2.5 c-ares/1.7.1
J2C Decoder Version: KDU
Audio Driver Version: FMOD version 3.750000
Qt Webkit Version: 4.7.1 (version number hard-coded)
Voice Server Version: Vivox 2.1.3010.6270

Settings mode: Firestorm
Viewer Skin: firestorm (grey)
Font Used: Deja Vu (96)
Draw distance: 96
Bandwidth: 1000
LOD factor: 2
Built with MSVC version 1600
Packets Lost: 12/2,758 (0.4%)

Link to comment
Share on other sites

Not on wireless - and once I've got everything cached I run just fine -  ping time is fine - DSL but get between 8-10 download and between .5 -1 upload.  I DJ and stream with no connection issues.   And with HTTP textures turned off I don't have any problems.   And I am fine using the Catznip viewer - perhaps they don't use HTTP textures?

 

 

Link to comment
Share on other sites


Fiddlejenny Rain wrote:

Not on wireless - and once I've got everything cached I run just fine -  ping time is fine - DSL but get between 8-10 download and between .5 -1 upload.  I DJ and stream with no connection issues.   And with HTTP textures turned off I don't have any problems.   And I am fine using the Catznip viewer - perhaps they don't use HTTP textures?

 

 

If I remember right Catznip defaults to HTTP textures off. I'd advse you to try to find and fix your HTTP texture problem though because they're going to be used more and more and when they WORK they're a lot faster. Certain routers have problems with the multiple data paths SL uses. What kind of router do you have, and do you have a firewall?

Link to comment
Share on other sites

Same problem as I have. It's the router as Ansariel said. If the textures are in your cache on your hard drive, the router has no issue but soon as it has to download a flurry of new textures, it's freeze and crash time. One of these days I'll get around to buying a better router than the one my ISP gives out.

Link to comment
Share on other sites


Theresa Tennyson wrote:

If I remember right Catznip defaults to HTTP textures off. I'd advse you to try to find and fix your HTTP texture problem though because they're going to be used more and more and when they WORK they're a lot faster. Certain routers have problems with the multiple data paths SL uses. What kind of router do you have, and do you have a firewall?


Niran's is the same with HTTP Textures off by default. Mine is a Huawei HG 556a, replaced a few times by the ISP but each one has the same issue with HTTP Textures. I'm thinking of getting a Fritz!Box 3370, which is a high performance home router.

Link to comment
Share on other sites

  • Lindens

*sigh*  Phone companies and ADSL.  More cut-corner engineering, I'm smelling.

For your particular case at this particular moment, disabling HTTP textures may be a best first step.

This is another environment where more attention is needed.  There's a community involvement role for those who are interested and capable of the work.  Some things I'd love to see:

  1. Packet captures using Wireshark or similar tools.  Need to be able to setup useful configurations, run reliable tests and be aware of the security and privacy issues involved in this.
  2. Vendor lock-in environments.  This applies to ADSL, some cable setups and regional practices (I'm looking at you, .eu) where customers are stuck with mandated equipment.  It isn't advertised but this equipment can generally be put into a bridged mode where it is no longer performing NAT, dhcp, etc. and users can take over the routing tasks with their own equipment.  To do this, you need some technical skills but there is a course of action here with several payoffs.  Faster service for those who like to do this.  Evidence to take to communications vendors that their equipment isn't adequate.  Adding to the knowledge base of known good and bad hardware.

Anyone interested?

Link to comment
Share on other sites

me !!! I do it

I got ADSL and I live other end of the world. I also dump my ISP provide Thomson speedtouch modem. is useless !!!

I get a Belkin N300. brmmm !!! but is different problems now lol. but oh! well

+

if you make some kinda test script thingy for us to follow then I be happy to do that. and give you whatever data you want. wire sharks or whatever. just say how to set up. and what to do. and where to send

bc I got a simboard and I want it. to go. like fast and not crasho (:

+

ps. can do both modems if you like. the Thompson and the Belkin. they both work with my ISP

 

Link to comment
Share on other sites

  • Lindens

16, I would actually like to get a Wireshark packet trace from the Thompson if it is that bad.

I'm going to see about getting some router pages up on the wiki.  I'd love to collect suggestions somewhere in the forums but I'm not certain how effective that will be...


m

Link to comment
Share on other sites

if you make a wiki instruction about how to set up the wireshark parameters for the session that be good. I can do that.  however you want it

I got 7zip so can compress it in some format you want. probably have to chop up the wireshark file before compress bc is quite big. but if can say on the wiki an easy way for us to chop and compress then that be good as well

+  

then we can make a BUG report maybe with a special name/title so you can find easy on the JIRA. can attach the wireshark session to it with the viewer logs

can set up the sessions on the magnum/blue steel etc sandboxes inworld maybe. or Beta grid. so you can set up the sim how you want for the testing. like load it up with scripted objects with textures changeouts that you want to test for 

then can maybe make a post thread on here about it. so we can comment/feedback on here the forum and not on the JIRA about what is happening. with each other as well

i can make vids recording of my UI as wellof the viewer session as well if you like and upload where ever you say. I write and chat like rubbish and not explain myself very well even when I try. so can just give you the vids and the wiresharks and the logs. you can work it out faster that way than me try explain it anyways (:

 

also maybe can put a notice/advice about it in the SecondLife Beta group. some people in that group will help most likely if they can

+

just on the http inventory. I quite often get the loading.... and the spinning mouse icon. it never stops and cant rez from inventory quite often until it does. so to fix I just keep flipping it back and forth between HTTP and UDP until it stops. some days works. some days not. but oh! well (:

 

Link to comment
Share on other sites

  • Lindens

The difficulty with Wireshark, or any tool like it, is that it raises a security concern.  These tools can reveal any and all information visible on a network.  All data collected needs to be handled and treated accordingly and never made available publicly. 

 

Link to comment
Share on other sites

yes ok. can understand that from your pov. the LL company. the big boss probably having kittens about it already (:

+

what about viewer session logs? can give you the whole lot if you want. if they be any use

I did that when I made a BUG about my Belkin when I first got it. like couldn't login properly. I made the report and I made a pic of my UI. then a person goes: hmm! is it ok for me to upload my logs. so I go sure and do that. then theycame back and said: is this. do this. so do it and woosh! (:

BUG closed. everybody happy. specially me (:

Link to comment
Share on other sites

  • 2 weeks later...
  • Lindens

Glad you found a solution.  Noted the success in my tables (which I'm trying to turn into wiki pages or something useful).

If you later decide this router wasn't such a winner (sometimes it takes time to find the faults), please let us know.

m

Link to comment
Share on other sites

I have two laptops and both wont work with http get textures its painfully slow for textures to rezz even if atall, i have reliable internet and a year old BiPAC 7800N router one of the best money can buy, come the roll out of server side baking droves of people are going to leave sl! I know many people in sl myself that have the same problem!

 

edit to add with http get textures turned off, if i tp to a place i have never been before textures rezz within seconds

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3591 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...