Jump to content

Max mesh rigged ... problem


Whystler Courtois
 Share

You are about to reply to a thread that has been inactive for 3618 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

 

Hey all,

 

I mastered getting static uv mapped meshes into SL from max.  So, I thought I might try something with rigged meshes.  I'm having a problem getting a mesh into the uploader that is actually rigged.  Every time I upload it, it doesn't give me the options in the uploader that pertain to skinned meshes.  Here is what I've done so far.

I am using Max 2010

I have installed the proper SLav plugin, and also the proper autodesk collada exporting plugin.

I used the Slav plugin to produce a mesh to my workspace.  I only imported the legs and feet.  Everything else I unchecked for import.

I made sure that my units were set to meters.

The result was a fully rigged set of legs.  I went into the vertices of the legs and changed them significantly.  Then I selected a bone from the skeleton and moved it.  Everything is rigged properly.  I looked at the rig weights, and everything seems fine.

The legs are only rigged to the appropriate bones.  I had read somewhere that it is important that your mesh, no matter what it is, be somehow rigged to all of the bones.  So, I selected one vertex, and I rigged it at .001 (.1 %) weight to every bone that it wasn't rigged to.  So now all of the bones are spoken for in some regard.

I made sure that the editable mesh was converted to a poly mesh by using the "turn to poly" modifier.  I then collapsed that ppart of the stack so that I was left only with a poly mesh with the skin modifier added.  I moved some bones to make sure that after this was done that everything was still weighted, and sure enough, everything was stuck properly to the bones.

Then I prepared to export.  I exported it as an autodesk collada file (dae). In the export window, I checked "animations", all "deformations", "embed media", "convert geometry used as bones", and I made sure my units were set to meters and my Z was up. In the collada section, triangulate was checked, and just as an FYI, baked animations *was not* checked.  Most other things were not checked.

I exported which resulted with a dae file.

in SecondLife, I uploaded the model, and was presented with the upload window.  I could see the mesh intact and proper in the preview window.  However, any check boxes that involve skinning were dulled - meaning they could not be used.  I could not check these boxes that other tutorials say I should be checking.  So I'm assuming somehow it was not reading the item as something that included rigging.  No skeleton is seen in the preview window - just the mesh.

Any thoughts about what I am missing?

-Whystler

Link to comment
Share on other sites

Could be several reasons,

some i could think of:

- Did you try to instead of having one vert with all bone weights on 0.001 to pick a vertex that has 1 weighted to any Bone and then add to this one all other weightgroups with the weight of zero? keep in mind 4 influences are allowed on one vertice, more make trouble.(seemed to do the trick when i had issues with a max export)
(http://wiki.secondlife.com/wiki/Mesh/Exporting_a_mesh_from_3ds_Max bottom of the page)

- Did you alter the skeleton in any way? changed relations between bones. The skeleton has to have precisely the same hirarchie and naming as the default one.

- mFootRight, mFootLeft Bone- / Weight-Groups are missing (if it's not in the importet Armature/Skeleton, you have to manually add these)

- (you prolly did it already) but make sure there are no vertices left without being weighted to any bone.

- I'm not sure about problems and issues with the Max2010 exporters. Might be an issue with that. Maybe read up on common issues. Or try the first to FBX and then to DAE export method.

- in addition here is an older thread about that issue of the skinweights/bones not showing up in the exporter: http://community.secondlife.com/t5/Mesh/Rigged-mesh-no-joints-or-skin-weights/td-p/1311901
(its not only about max, but might have pointers to help you)

Cheers, Code.

Link to comment
Share on other sites


Whystler Courtois wrote:

 

I selected one vertex, and I rigged it at .001 (.1 %) weight to every bone that it wasn't rigged to.

That's probably your issue right there.  SL supports a maxium of four influiences per vertex.  You've got a vertex with 26 influences.

You seem to have misinterpreted whatever you read about the mesh needing to be rigged to all the bones.  Assuming it was true information, all it would have meant was that all 26 bones must be correctly listed and accounted for in the COLLADA file.  If a particular bone is not actually influencing any vertices that's fine; it just has to be there.

It's also possible that the bone you moved could be screwing things up, depending on how you moved it.  All bone rotations should be at zero.

 

So you know, here are some additional common causes for the skinweights options to be grayed out in the SL uploader:

1.  One or more bones is incorrectly named.  Make suire they all have names like mPelvis, mTorso, mChest, etc.  Some programs will add prefixes or suffixes to the names of imported objects.  If that happened, make sure to delete the extra characters from the names.

2.  Not all bones present in the COLLADA file.  All 26 bones must be listed

3.  Too many influences per vertex.  As I said above, you can only have up to 4 infulences on any one vertex.

4.  Wrong COLLADA version.  SL supports COLLADA 1.4.  If your exporter is writing to a different version, you can have all sorts of problems.

5.  Wrong type of skeletal bind.  SL supports smooth binds only.  Again, I don't know enough about Max to know what other kinds of bind options it has.   I'm sure some of our Max users here can comment more intelligently on this.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3618 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...