Jump to content
Sign in to follow this  
Curious Hazelnut

Flickering and video artifacts on Intel HD Graphics 4000, is this a known issue?

Recommended Posts

I had to travel for work this week and am stuck with my laptop for SL. I've got a Core i7 with the integrated Intel HD Graphics 4000 and 4GB of RAM on this thing. (Asus Zenbook Prime for those who care). There are no upgrade options at all.

It runs SL better than I expected. It actually gets up to 5fps on ultra and a usable 25 to 35 fps on medium graphics. That is far better than I expected of an ultrabook.

The problem I found is that there is a sort of rainbow highlighting of buttons and check boxes in the SL dialog (like prefs and inventory) and there is random flickering of red and cyan in text boxes (chat history, IMs). It is very distracting and definitely not part of the standard set-up since I don't see this on my desktop.

I searched the KB, forums, and google for these issues but didn't find any clear mention of them or a solution. I verified that Windows 7 is up-to-date, SL viewer is up-to-date, and the Intel graphics drives are up-to-date. Intel provides a convenient app on their website to verify you have the latest version of applicable drivers.

So, first off, is this a known issue that I just didn't find? If so could some kind person point me to what I missed?

If it's not a known issue, is anyone else experiencing it? And what (if any) solutions have you got?

Last ditch, any hints on the best way to write this issue up so that LL will have enough information to maybe fix the problem?

 

Share this post


Link to post
Share on other sites

That's a shader issue in combination with the Intel drivers/hardware. Best you can try is using a different driver version or try a different/older viewer.

Share this post


Link to post
Share on other sites

Pretty much the best you can do is lower the graphics options so everything is deactivated and start enabling one by one (or two by two) until you get the problem. Then just leave that particular option diabled or lowered.


Sadly Intel pretty much sucks in the performance/driver quality department and doesn't put as much effort into fixing things as much as AMD/ATI or Nvidia do.

Share this post


Link to post
Share on other sites

Firestorm team are working on a fix for that in the next release (hopefully official viewer will follow suit too).

As a temporary fix until we get that new viewer, you can uncheck "Basic Shaders" in gfx options, that makes it go away.

Share this post


Link to post
Share on other sites

Thanks so much for posting this temporary fix!!!!!!   Worked like a charm.  I was wondering why I was having that problem when my laptop has 16GB of ram, but you explained it well and gave a good solution.

Share this post


Link to post
Share on other sites

I believe I have the same artifacts described here with Mesa / Gallium on Radeon. I've kept looking for ways to fix it for days, and found this topic in the process. See this thread where I also posted some screenshots.

I'm glad to hear Firestorm is working on a fix. I tend to defer Firestorm to other viewers, but it sounds like I'll be going back to it if they fix it first. Hopefully SL and / or the video drivers will fix it soon, whichever has the fault.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...