Jump to content

Maya 2013 and hip animation problem


Fiona Branagh
 Share

You are about to reply to a thread that has been inactive for 3549 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I've been struggling with this for a few weeks... so I figure I've tried the obvious things (I hope?) and not so obvious, before asking for ideas here.

 

Problem: I am using a quad avatar, custom mesh/offset joints, in Maya 2013. Animations requiring the hip to move seem to be off, as if the hip were facing in the wrong direction (example: when I see the hip from behind in Maya, it tilts properly down to the left then right for the walk. In SL, the avatar tilts forward and back.)

Info:

I am using the only BVH exporter I can find for Maya, which is listed on these forums.

All the other joints seem to be behaving properly.

I bound the mesh to the SL skeleton without rotating or moving the skeleton's hip in any way, or importing it into a scene.

All the other joints were put in the right position without rotating anything (only translation.)

 

Question: Any thoughts on how to fix this? I don't have the option of not animating the hip, which is going to be really important for a lot of motions.

Thanks in advance!

Link to comment
Share on other sites

  • 1 month later...

I'm running into the same problem, the hip rotation and translation does not import properly yet most other joints import fine (the wrists also do not import properly):

I used the abbloch.com rig and animation bvh export 1.2 and I also tried the 1.5 and both have the same hip rotation problem as the OP. 

Tests I ran:

1.) I tried all of the axis combinations (Major and Minor) and they did not solve the hip rotation and translation problem.

2.) I tried the skeleton animation by itself - with no IK and just FK rotations (no ik handles, constraints, or set-driven keys) - to no avail on the hip solution. 

3.) I tried the hip with no higher node on it's hierarchy / so to isolate any potential translation conflicts - hip node is top node. Hip rotation export was still inaccurate.

4.) Altering World Settings: I tried altering the World Setttings, setting Working Units > Linear to centimeter, millimeter and so on to no effect. I tried altering the World Settings , setting Working Units > Angular to radians to no effect.

5.) Testing with qavimator.exe: I attempted also an even simpler Maya test: I rotated the "root control" and keyed it at 45 degrees on the X axis and exported the bvh. On import into Second Life, the hip is completely vertical at zero rotation. I then, tested the Maya exported bvh by importing it into qavimator.exe to see if qavimator reads the bvh the same as Second Life. Interestingly, qavimator reads the Maya exported bvh accurately (with hip rotated at 45 degrees) and will export it back out as a bvh. But then when trying to upload the qavimator bvh into Second Life, Second Life will not read it and will state "Failed to initiate motion." Which leads me back to the hypothesis that something is wrong with the Maya bvh exporter.

As these rigs rename the mPelvis to "hip," which Second Life asks for, Second Life will recognize the hip node, but it will not accept it's rotation values, or the bvh exporter does not export the values of the "hip" accurately. Something is lost inbetween.

Also, I notice that qavimator has a "position" node above the "hip" node. Should it be perhaps the Maya files should contain a "position" node / so to be able to pipe the equivalent of translation values into the bvh export?

Anyone find a fix or work-around to the hip rotation / translation problem?

(BTW, I'm using Maya 2009)

Link to comment
Share on other sites

Problem Solved...

Upon seeing the only difference between the previous Maya bvh export, and the typical qavimator export, I saw that the qavimator has a preset T Pose built in on it's first key frame, so I replicated that in Maya.

Solved the hip translation and rotation problem by:

1.) Adding the T Pose (zeroed out) keyframed at frame 1. (Essential for the bvh export to work)

2.) Setting the Time Range to "Manual," and setting the range of animation, on export settings.

  • Like 1
Link to comment
Share on other sites

  • 1 month later...
You are about to reply to a thread that has been inactive for 3549 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...