Jump to content
Sign in to follow this  
Mac Shoreman

What is the explanation to why "non-deferred" is set default in Viewer 3?

Recommended Posts

For some reason the rendering feture for automatic alpha mask is set to "non-deferred" in Viewer 3 (and Catznip viewer too). Is there a valid good reason for this?

I need to explain this to customers that can't see things as they was made to be. They get scared when I tell them to start the "Advanced" menu, activate the "Developer" menu and under "Rendering" un-check "Automatic Alpha Masks (non-deferred)".

Share this post


Link to post
Share on other sites

Tell them it's enabled by default because it works 99% of the time, provides a modest speed improvement and helps minimize alpha sorting problems. Of course saying that won't exactly help your case for why they should disable it, so maybe it would just be better if you lied.

Alternatively you could figure out why your items are having problems with this feature and try to fix it.

Share this post


Link to post
Share on other sites

Like leliel said, I'd go to fix the alpha texture in your products. I can say from personal experience and discussion with Runitai Linden that LL won't fix automatic alpha masks again or turn it off by default.

Share this post


Link to post
Share on other sites

For a quick fix on affected textures, it often works to select that prim face in the SL editor and set its overall transparency to 1%. If that doesn't give the desired effect, you may have to go back to the drawing board and clean up the original texture's edges in your graphics editor.

Share this post


Link to post
Share on other sites

Thank you Cerise for a good solution both creator and customer can use (that is if the product with the texture applied is set to modifiable).

How ever I am still curious what is wrong with my alpha textures?

Share this post


Link to post
Share on other sites

Nothing is really wrong with textures that get this harsh effect now. It's just that the render automatically switches to 1 bit alpha when it sees lots of full transparency now. This helps with the old alpha fighting problem, and can help frame rates too. But, it does make a lot of textures that used to look fine, now look bad. So, "fixing" is really more about adapting to the way things work now. You can trace your edges with a neutral tone if you want to make things work with the 1 bit alpha, or you can tweak the textures to have less full-on transparency so they don't switch over to 1 bit in the first place. It will take trial and error.

Share this post


Link to post
Share on other sites

Yep. I mean, there is a forula in the viewer that choose the textures that get this treatment, but most people paint with brushes and not calculators.

I imagine that some sort of offline utility or plugin could make it quicker to learn if a particular image will have to deal wtih this, but that would only make the annoyances a little quicker to iterate through, no less annoying.

Share this post


Link to post
Share on other sites

This is definitely an annoyance, no disagreement there. However alpha textures have been a nightmare to deal with in real time 3d rendering for decades now, it's the price you pay for using them.

Another thing to think about is that the automatic alpha masks is a good thing over all. Changing your textures so it doesn't kick in is one option, but you could also adjust your textures so they don't look bad with alpha testing ( mostly avoid alpha gradients, go for sharp edges).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...