Jump to content

Problem with 'touching'


You are about to reply to a thread that has been inactive for 2502 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

All of a sudden I am finding that touch scripts are not working for me.

If I touch, say, a sofa with poses then no menu pops up.  If I sit on it then the menu does appear, and 'touching' while sat also brings the menu up.  Once I stand up then once again I can't bring a menu up by touching.

The main problem is that it also means that I can't open boxed items.  I can rez them, but there is no 'touch' option in the pie menu.

I have tried using Firestorm, Phoenix, and the standard viewer, and I have the same problem in all viewers.

Here's hoping that someone can help....

Link to post
Share on other sites

Did you recently rezz a large decorative object like a "sim surround", or are you possibly trying to do this in a mesh house? Sometimes the touch gets "intercepted" by objects like this because you're actually inside them and the viewer thinks you're touching them. It's especially a problem if  you're not standing close to theh object you're actually trying to interact with.

Link to post
Share on other sites
  • 8 months later...

This problem was bad yesterday, but seems better today in the sims I use most often, though I am still getting reports of it from various people who work with me.  My guess is like most such incidents the execution command is getting timed out or lost for some reason, and the button either does not appear or is not activated.  Oddly this does not happen to everyone and does not seem to depend on either the nature of someones computer or where they are connecting to sl, so my guess is it is purely random and is occuring due to someting going on within server timing and not the scripts themselves.


Another problem that I have notice recently is that in Le Tiger sims allocated memory is running abnormally high and in the three didgit and rezz times are slower than in other sims.  Again this does not seem to have an obvious reason such as over use of the sim, and little in the sims have changed in the last two weeks that would account for the memory increase.  Though on the surface a different issue I suspect it is one that needs investigation if tomorrows restarts do not fix the issue as they have in the past when memory allocation started rising.  Also oddly enough in Blue Steel sims memory allocation has fallen slightly despiting using the same code as Le Tiger so this would seem more a timing issue than a code issue and may result from something that happened during the work ups for the last few restarts.

Link to post
Share on other sites


BeauBelleUK wrote:

I don't think that is the problem, I'm afraid.  I have tried in three different areas (including a sandbox), and also, I am able to select the items and delete them, just the 'touch' option is greyed out.

This would happen if no script with a touch event handler is running

Scripts are set 'not running' if compiled with an error and saved or if you uncheck 'Running'

:smileysurprised::):smileyvery-happy:

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 2502 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...