Jump to content

SL Linux Viewer Not working in Any Mint 14 version - Do you know one that works?


Phoenix Ghostaltar
 Share

You are about to reply to a thread that has been inactive for 3116 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

The folks ate Mint are scratching their heads. I am getting errors on both 32 and 64 bit versions of Any viewer on all Mint 14 versions. I have tried Mate 32 bit and Cinnamon 64 bit. I'm using Mate 32 bit now.

I have tried the official SL viewer for Linux. I have tried Firestorm, Phoenix, Catznip and others.. all the same errors. In the 32 bit versions the errors are:

libGL error: failed to load driver: r600
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
The program 'do-not-directly-run-firestorm-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 30 error_code 11 request_code 154 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
*** Bad shutdown ($LL_RUN_ERR). ***

I'd like to know if anyone knows a viewer that does not give these errors. Or if you know of a fix ( i have tried everything) please let me know. ( the 64 bit errors are different but those are all the same across all viewers i've tried too)

 

Edit: I didnt have any html in this message. This forum thought some of the code was html and removed it, so i dont know how much of the original errors you will see.

Link to comment
Share on other sites

Hello.

The message libGL error: failed to load driver: r600 indicates that you re using the free driver for your graphics card.

You should install the proprietary driver and try again.

To install additional drivers, please run the "Software Sources" tool from "Menu->Preferences->Software Sources" and click on the "Additional Drivers" tab.

After instaling the driver, restart your system.

J.

 

Link to comment
Share on other sites

Hi Phoenix, yes you should install the proprietary driver. That'll probably help. I had similar problems and had a friend sorting out my  computer via Team Viewer before installation of the SL viewer worked. I recommend the Singularity viewer. I installed the 64-bit Linux version on my 64-bit Mint.

Hey, didn't LL say Linux viewers only work on 32-bit systems? They have no idea what they are talking about. Things like that are the reason why I'm staying far off any LL viewers since years. Try Singularity, it's The **bleep**! :heart:

Link to comment
Share on other sites

Thanks J. That worked for me, all viewers work in Mint 32 bit now. Now I have to figure out a way to get it working in the Awesome VLocity 7.0 - Vector Linux's 64 bit distro. It's slackware based and doesn't have support for 32 bit apps out the box.. but it did have my proper ati drivers installed on it...perhaps i'll try he singularity 64 with that one.

Link to comment
Share on other sites

In the next few weeks I'[m going to be doing some experiments with Mint13 64 bit. I'm picking 13 instead of 14 because just like you, nothing I did in 14 seems to work. Also, my particular video drivers aren't available for anything after Ubuntu 12.04 and it's downstreams. the last linux distro that I got sl working on was based on Ubuntu 11. but in fairness, I skipped distros based on 12.04 before, so maybe that'll work. As an added bonus, mint 13 will remain supported until 2017.

I'll keep an eye on this thread, and if my exdperiments bear any fruit, I'll post them here. check the thread I started called "Ubuntu troubles, would debian work better for me?" Others have been kind enough to offer me plenty of advice there. Maybe we have the same problem and their advice can help both of us.


*edited to add... The workaround that I've been told about is to add the 32 bit libraries for better multiarch support. I know several others who tried it, and it worked, but I have to get past the same driver issues you have to be able to try it for myself. And it's worth working around since the 64 bit versions are better with multi-core processors.

Link to comment
Share on other sites

  • 2 months later...
You are about to reply to a thread that has been inactive for 3116 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...