Jump to content
  • 0

An animation will not stop after a crash, despite doing everything. How do I get help?


Enigma Kamm
 Share

You are about to reply to a thread that has been inactive for 3662 days.

Please take a moment to consider if this thread is worth bumping.

Question

  • 0

Unfortunately, there is a way for a script to be wriiten so that it does not release permissions when you stand, which is the normal behavior.  The object, therefore can continue to animate you untill its script is reset or the object is deleted.  We've had discussions about this in the LSL scripting forum a few times, and the consensus is that this is a weakness in the SL permissions system ( a "bug", if you like) for which there is no cure at the moment.  Well, no cure except that if you can identify the object and delete it (or convince its owner to delete it), you're free.  The bright spot is that the script can only animate you if you are in the same sim, so if you teleport to another sim, you should find that the animation stops.

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Unfortunately, there is a way for a script to be wriiten so that it does not release permissions when you stand, which is the normal behavior.  The object, therefore can continue to animate you untill its script is reset or the object is deleted.  We've had discussions about this in the LSL scripting forum a few times, and the consensus is that this is a weakness in the SL permissions system ( a "bug", if you like) for which there is no cure at the moment.  Well, no cure except that if you can identify the object and delete it (or convince its owner to delete it), you're free.  The bright spot is that the script can only animate you if you are in the same sim, so if you teleport to another sim, you should find that the animation stops.

Link to comment
Share on other sites

  • 0

The problem persists in every sim I go to. The problem started when using the Firestorm viewer, but persists when using the official Second Life viewer and Phoenix. I only loaded Phoenix in order to use the animation explorer in that viewer (not present in the other two), after advice.

Link to comment
Share on other sites

  • 0

This may be a stupid question, but in your post I do not see that you have tried using an "animation stopper" device.  Go to Caledon Oxbridge University.  Near the arrival point there is a black and gray fluted cone object, about a meter high, that says "touch here to stop animations" above it.  Left click the cone and then accept its request to animate your avatar.

Or you can get your own animation stopper, like this one:  https://marketplace.secondlife.com/p/MAGIC-WAND-Stops-Animations/3475671

Link to comment
Share on other sites

  • 0

No, it is not a stupid question at all: my apologies, I did not include all the detail. When I worked in-world with a helper from this site previously, I tried a number of different animation-stopping devices, as well as the simple "stop all animations" from the menu.

Link to comment
Share on other sites

  • 0

I'm certainly no expert but I notice that there are "Revoke Permissions" checkboxes in Preferences / Firestorm / Protection and that "Never" is the default state. I would try enabling "Revoke on Stand" and see if that gets you anywhere. (I assume you would need to rez your boat and use the animation for this to take effect).

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3662 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...