Jump to content
Sign in to follow this  
Jared Spearsong

Issues with mesh upload

Recommended Posts

Hey guys... I've got a friend that is using maya to make a mesh jacket for me. At first we had the issue of it having no physics when trying to upload, but we fixed that. Now when we try to upload it, there are 3 issues... it comes in extremely tiny, but can be stretched to a bigger size.... it's almost invisible on the outside when you  cam around it and when trying it on, it's completely crazy and there's a long box that goes down my whole body. If there's anyone that can help me with this, I'd really appreciate it!! Thanks!

Share this post


Link to post
Share on other sites

The reason it is so tiny is because the maya scale is not the same as the secondlife scale. 1maya unit = ?? meters in secondlife

The reason it is a invisible is because faces/normals only face one direction. If you have the face facing the wrong direction the backside of it is invisible which allows you to see through it, making your jacket have that strange quality.

I have no idea what the box would be, could you post a screenshot?

  • Like 1

Share this post


Link to post
Share on other sites

By Googling I found this:

"The measure units by default on Maya are cm but there are different units that Maya can work with, such as mm, meters, inches, feet or yards."

Second life uses meters.  So you need to design in meters in Maya.

If you design in centimeters, and  think that it is equal to meters in SL (which it is not),  then you need to upscale your design 100 times bigger for it it to appear in the right scale in SL.
1 meter [m]= 100 centimeters [cm]

  • Like 1

Share this post


Link to post
Share on other sites

While it probably isn't YOUR issue on the size thing, it is good to note that if you are uploading on Aditi for testing there are times when the EXACT same dae file will upload "petite" size and then the next day (or sometimes only an hour or so) it will be back to what you expect -- and uploaded previously. It is very strange and disconcerting. I can only guess they are playing around with the uploader.

So, just in case other folks are reading this, wanted to mention that. I haven't noted that problem on the main grid, but I do much more testing than actual finished uploads *wink*.  I use BLENDER.

  • Like 1

Share this post


Link to post
Share on other sites


Jared Spearsong wrote:

it comes in extremely tiny, but can be stretched to a bigger size....

As others have already stated, the issue is unit discrepency.  Your Maya units are set to something other than meters.  By default, Maya uses centimeters, so if you've never changed that, then your objects are 100 times smaller than SL wants them to be.

There are three ways to fix it:

1.  Change your working units to maters, in Maya.  Click Window -> Settings/Preferences -> Preferences.  The Preferences dialog will open.  In the left hand column, click Preferences.  Under where it says "Working Units" select "meter" from the dropdown menu, and then click Save at the bottom.

-OR-

2.  Set your COLLADA exporter to change the units to meters, upon export.  Instructions for this will vary, depending on what exporter you're using.

-OR-

3.  After you export, manually edit the .dae file, to change the units to meters.  To do ths, open the file in a text editor, such as WordPad.   You'll find the line that defines units near the beginning, generally within the first 25 lines or so.  If your Maya units were set to centimeters when Maya wrote the file, then the line will look like this:

<unit name ="centimeter" meter="0.01"/>

Change the 0.01 to 1.00, and your objects will become the correct size. 

Optionally, you can also change the word "centimeter" to "meter", if you want.  It won't make any difference for SL, but it will help keep things consistent, in case you ever end up using the same file for other applications that do care about such things.

 


Jared Spearsong wrote:

it's almost invisible on the outside when you  cam around it

It sounds like you've got your normals reversed.  In 3D modeling lingo, "normals" are the directions in which light reflects off of surfaces.  Each polygon has, among other things, what's called a "face normal".  Whichever direction the face normal is pointing is considred to be the front of the polygon.

By default, Maya displays double-sided polygons, so every surface is visible from both the front and the back.  Realtime environments like SL only display single-sided polygons, meaning surfaces are only visible from the front. 

Whenever you're modeling for realtime (games, virtual worlds, etc.), you MUST keep track of which way your normals are facing, so you don't end up in the situation you're in right now. 

One way to do this is to enable backface culling in Maya, so that things will look the same way they'll look in the game.  With backface culling turned on, only front faces will be visible; backfaces will be invislble.

Maya offers several different ways to enable backface culling:

  • You can enable it globally, by clicking in the main menu bar: Display -> Polygons -> Backface Culling
  • You can enable it just in a specific viewport, by clicking at the top of the port:  Shading -> Backface Culling
  • You can enable for just a specific object by first selecting the object, and then clicking in the Attribute Editor: object's shape node tab -> Render Stats -> uncheck Double Sided

There are other methods, as well, but those are the ones you'll likely use most often.

Another option, as an alternative to enabling backface culling, is disabling two sided lighting.  This will turn backfaces black, instead of invisible.  You can do this in any viewport, by clicking at the top of the port: Lighting -> uncheck Two Sided Lighting.

You can also enable normals display, so you can look at the normals themselves, to see which way they're pointing.  They will appear as lines protruding from the front side of each polygon. 

Just as before, Maya offers lots of different ways to enable normals display:

  • You can enable it globally, by clicking in the main menu bar: Display -> Polygons -> Face Normals
  • You can enable it for a specific object, by first selecting the object, and then clicking in the Attribute Editor: object's shape node tab -> Mesh Component Display -> check Display Normal

Once again, there are other methods, but those are the ones you'll likely use most often.

 

To reverse a polygon's normals, first select the polygon, and then click in the main menu bar:  Polygons menu set -> Normals -> Reverse.  If you want to reverse the normals on the entire model, do it with the whole model selected.  If you want to do it to just part of the model, go into component mode, and select just the individual faces you want to flip.

Notice that like most menu commands in Maya, the Normals -> Reverse command has an options box next to it.  I'd suggest you open it up, and take a look at the options.  As always, for a complete explanation of what each option does, click Help, at the top of the options box.

 

 


Jared Spearsong wrote:

when trying it on, it's completely crazy and there's a long box that goes down my whole body

Sounds like it's not rigged properly. There are any number of ways your friend might have screwed that up, so without knowing more about what exactly he did, it's hard to suggest a solution.

My guess is he inadvertently weighted some of the vertices to the avatar's feet, so the corresponding parts of the jacket are getting pulled downward.

I would invite your friend to post here himself, so we can have a more direct conversation about correcting his techniques.

  • Like 1

Share this post


Link to post
Share on other sites

We are so much closer now, it's rigged correctly and the size is right, now we're working on making it not invisible on the outside! Thank you all so much, this was seriously a big help!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...