Jump to content

Deploys for the week of 2013-01-07


You are about to reply to a thread that has been inactive for 3010 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

We're starting off the new year with a bang, with 2 new performance-improving projects entering RC.  Here are the updates:

 

Second Life Server (main channel)

The main channel is getting the version that was on all 3 RC channels previously.  This update includes a fix for a crash:

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Server/13#12.12.18.268345

Scheduled Tuesday 2013-01-08, 05:00-11:00 PST.

 

Second Life RC BlueSteel and Second Life RC LeTigre:

BlueSteel and LeTigre are getting a new project, which should improve simulator performance when avatars are region crossing to and from the region.

Scheduled Wednesday 2013-01-09 07:00-11:00 PST

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_LeTigre/13#13.01.04.268719

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_BlueSteel/13#13.01.04.268719 

 

Second Life RC Magnum:

Magnum is getting an update to the interest list subsystem.  This update should reduce the bandwidth usage of viewers due to object updates, and should improve simulator performance, especially in sims with many connected avatars.

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Magnum/13#13.01.04.268722


The plans for Magnum have changed, due to a bug found in last minute testing of the interest list project.  Magnum will instead get the same region crossing project as the other two RCs:

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Magnum/13#13.01.04.268719

Scheduled Wednesday 2013-01-09 07:00-11:00 PST

 

UPDATE @ 2013-01-09 15:55 PST:

Due to a crash mode observed in simulator version 13.01.04.268719, the new region crossing setting has been disabled on the RC channels, as of 15:20 PST.  This means that the region crossings in the RC should now behave the same as they do with the main channel.  No action is required for this configuration change to take effect.

 

We will be monitoring this thread as the code gets released, so feel free to note any observations you have about the server updates.  If you have a specific bug you'd like to report, please file a Jira

 

Link to post
Share on other sites

Welcome back, Maestro, and Happy New Year.

Let us hope that this year proves to be one of more steps forward for SL, and one of fewer  "...what?  Ooops" moments!:smileytongue:

Edit at 4pm SLT:

Dear oh dear.  No, OK maybe it wasn't the software update, but it is hardly going to improve LL's image now, is it?

Link to post
Share on other sites

Hey Maestro happy new year!
I must say that already LL has started off the new year with some awesome tech support. At the start of December we were on a magnum channel and I posted here some concerns I had with some relatively minor glitches such as objects rezzing upside down or rezzed in one spot and appear across sim. Jumping forward to around Christmas eve these glitches progress in a way indicative of a cascading failure of either hardware or  software of the channel I was on.


It got to a point where scripts in objects would revert back to previous or test versions and sim physics was dropping often to the low 20's. I filed a ticket thinking it would be days due to the holidays before I got a response but to my amazement late Christmas eve just a few hours after filing it was being looked into and repairs attempted. Unfortunately while many of the glitches were repaired new ones popped up. The worse of all were the changes in permissions of objects and scripts to full on their own. Those of us that either write scripts or build for a living know that this was a disaster. 


So again I filed a ticket thinking being new years eve there wouldn't be a response after all it was a major holiday. Within a couple of hours the sim was being checked out and I was contacted for further information and a solution was suggested of a restart after repairs had been made. The restart caused another glitch to appear that caused the sim to roll back at least 12 hours(this happened to me earlier that day on a restart I had done but being only an hour I didn't pay much attention to it).I would like to commend Boris Linden for busting tail to repair the roll back and find a solution by working into the wee hours of the night until it was fixed.


While we did end up being switched to the main server(this cleared all the little glitches) I did not expect such exemplary customer service during the holidays! Hopefully these glitches do not follow the magnum  code being propagated to the main so I will continue to gather all data and pass it along good and bad. Thanks for the professional customer tech support and being part of finding a solution!

Link to post
Share on other sites

Hey Maestro! Happy New Year!

I am seeing some performance hits on Livingtree (Main Channel) since today's restart. Owner is filing all the relevant tickets as we speak, but mesh is not loading, friends lists not loading, etc. Not anything I would have expected, nor that I'm seeing elsewhere.

Link to post
Share on other sites


Marianne McCann wrote:

Hey Maestro! Happy New Year!

I am seeing some performance hits on Livingtree (Main Channel) since today's restart. Owner is filing all the relevant tickets as we speak, but mesh is not loading, friends lists not loading, etc. Not anything I would have expected, nor that I'm seeing elsewhere.

Okay, thanks for keeping us posted.  I wouldn't have generally expected that either - something on the sim host may be acting up.  Support tickets are probably the best route to take at this point.  Happy new year to you too!

Link to post
Share on other sites

Not sure if this is relevant or things are just up in the air at the moment but I am seeing packet loss on Le Tigre - I am on a wired connection and normally never see packet loss stats!  I know that Le Tigre is not due for a roll till Wednesday.

You are at 292,575.0, 278,304.0, 3,336.2 in Riback located at sim7658.agni.lindenlab.com (216.82.36.225:13002)
Second Life RC LeTigre 12.12.18.268345
Error fetching server release notes URL.

Thanks

Black

 

 

 

Link to post
Share on other sites

Since this mornings rollover of the main channel I'm experiencing trouble rezzing on my full region.. also when putting objects in edit .. 'edit' in the pie menu can be greyed out ...Also was suddlenly logged out once.   I've tried a couple restarts of my own since, but still seems to be a problem.   just wanted to give you a heads up. if it continues I'll ol course file a ticket.

Link to post
Share on other sites

Hey Maestro :)

do we see this issues due that amazon have some network issues?

trace routing from europe looks so horrible:

C:\>tracert my.secondlife.com

Tracing route to appid549761herokucom-728689208.us-east-1.elb.amazonaws.com [184.73.250.146]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  xxxx@home
  2     7 ms     6 ms     6 ms  xxxxx@porvider
  3     9 ms     6 ms     9 ms  yyyyy@porvider
  4     7 ms     7 ms     7 ms  f-ed4-i.F.DE.NET.DTAG.DE [62.154.14.130]
  5     7 ms     7 ms     7 ms  80.156.161.46
  6     7 ms     8 ms     8 ms  xe-1-1-3.r20.frnkge04.de.bb.gin.ntt.net [129.250.5.221]
  7   138 ms   111 ms   121 ms  ae-1.r21.asbnva02.us.bb.gin.ntt.net [129.250.3.20]
  8   101 ms   101 ms    95 ms  ae-2.r00.asbnva02.us.bb.gin.ntt.net [129.250.3.114]
  9    94 ms    94 ms   100 ms  ae-4.amazon.asbnva02.us.bb.gin.ntt.net [168.143.232.50]
 10   101 ms   130 ms    96 ms  72.21.220.65
 11    97 ms    91 ms    92 ms  72.21.222.141
 12     *        *        *     Request timed out.
 13     *        *        *     Request timed out.
 14     *        *        *     Request timed out.
 15   101 ms    96 ms    96 ms  216.182.224.57
 16     *        *        *     Request timed out.
 17     *        *        *     Request timed out.
 18     *        *        *     Request timed out.
 19     *        *        *     Request timed out.
 20     *        *        *     Request timed out.
 21     *        *        *     Request timed out.
 22     *        *        *     Request timed out.
 23     *        *        *     Request timed out.
 24     *        *        *     Request timed out.
 25     *        *        *     Request timed out.
 26     *        *        *     Request timed out.
 27     *        *        *     Request timed out.
 28     *        *        *     Request timed out.
 29     *        *        *     Request timed out.
 30     *        *        *     Request timed out.

Trace complete.

Link to post
Share on other sites

So, more fun today?

Over the last 24 hours, you may have noticed that your sim may have experienced some lag or other technical difficulties. Please note that this is NOT an issue with your sim. ~~ ~~ Linden Labs had a major issue yesterday and the issues that you may be experiencing, have effected over 70% of the Second Life Grid. Today, Linden Labs has fixed the issue, and is in the process of restarting every sim on the grid with an install of the solution. ~~ ~~ You can track their process by checking the grid status at http://status.secondlifegrid.net/ ~~ ~~ Thank you for your patience, I know it can be frustrating, as it is for us as well.

Link to post
Share on other sites

I'm seeing repeated crashing as well as periodic caps failure-like conditions in many RC regions where rezzing, attaching from inventory, url granting, teleporting, region crossing and login to region all fail. The region, Mauve has crashed 6 times as of this writing and the region, Columbia at least twice since their rolls to the new server version today. Both have had caps failure-like conditions periodically.

Link to post
Share on other sites

The reproduction of objects at Le Tigre is missing or incomplete when I stand immediately outside and look into the region.
What I see is more or less deserted land.

Here are my date:

Second Life 3.4.3 (268262) Dec 17 2012 12:23:54 (Second Life Release)
Release Notes

You are at 287,765.0, 268,293.0, 23.0 in Nautilus - Suniaton located at sim9919.agni.lindenlab.com (216.82.46.61:13000)
Second Life RC LeTigre 13.01.04.268719
Error fetching server release notes URL.

CPU: Intel® Core i7-2600 CPU @ 3.40GHz (3392.39 MHz)
Memory: 8174 MB
OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 460/PCIe/SSE2

Windows Graphics Driver Version: 9.18.0013.0697
OpenGL Version: 4.2.0

libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
J2C Decoder Version: KDU v7.0
Audio Driver Version: FMOD version 3.750000
Qt Webkit Version: 4.7.1 (version number hard-coded)
Voice Server Version: Not Connected
Built with MSVC version 1600
Packets Lost: 1,767/269,772 (0.7%)

:smileysurprised::):smileyvery-happy:

Link to post
Share on other sites

Maestro

Not seeing issues such as those reported above, on Sim 8910 Woods of Heaven (LeTigre).  Some TPs are very slow, others are lightning fast!  Object rezzing seems marginally improved as does sculpty rezzing.

Sim stats and overall packet loss back to normal after last (UK) night's horrors.

Link to post
Share on other sites


Ayesha Askham wrote:

Maestro

Could you give the duty op in the Grid Status Page a boot please, the last two entries were never "resolved" or completed".  Unless the RC roll is still going on, of course! :smileytongue:

Good point, Ayesha.  The rolls are definitely finished, and I imagine the live chat maintenance is too.  I've notified the status page maintainer about that.

 

Regarding the region crossing performance on the RCs, it should be the same as what you see on the main channel at this point, since we disabled the new code via live config update yesterday afternoon, due to a sim crasher.

Link to post
Share on other sites

But you are inside looking out:)
I said from the outside looking in:)

The malfunction is still there, I checked again to day, but it looks somewhat different from one time to another.

Try to stand near the property line with your back to it and walk backwards across the line to the next region.
You will surely see something odd

:smileysurprised::):smileyvery-happy:

Link to post
Share on other sites

Dora

I have seen the phenomenon that you refer to several times, and not confined to LeTigre and the last roll either.  Sometimes a sim shows you its contents, then suddenly it all vanishes, only to return some moments later.  It doesn't seem to matter if the sims are contiguous or  diagonally linked.  It is a most disconcerting occurence when the sim you have just or its objects briefly vanishes only to reappear a few seconds later!:smileysurprised:

Link to post
Share on other sites


Ayesha Askham wrote:

Dora

I have seen the phenomenon that you refer to several times, and not confined to LeTigre and the last roll either.  Sometimes a sim shows you its contents, then suddenly it all vanishes, only to return some moments later.  It doesn't seem to matter if the sims are contiguous or  diagonally linked.  It is a most disconcerting occurence when the sim you have just or its objects briefly vanishes only to reappear a few seconds later!:smileysurprised:

Ah, it sounds like you're referring to BUG-141 "50 seconds after a region crossing, the previous region disappears.".  A fix for that bug is in the upcoming interest list update project.

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 3010 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...