Jump to content
Sign in to follow this  
HisaDrug

LL, Please no more updates !

Recommended Posts

 

About Viewer 3.4.3, 

First of all, I'm on Mac Lion, and last few updates were horribly disasterous considering my graphic drove right back to hello basic 2000. The sky files were missing, the grounds were all gritty, not to mention my avi's appearance was messed up as well as the skin got all blurred and pixelized. 

I tried to fix the issue by reinstalling the viewer several times and only Firestorm could save me from the trouble. 

Now the latest update 3.4.3 is going for the same issue on my SL, all the settings went on default mode and graphics are again horrible. I don't know why LL keeps toggling with the system..... but I hope they can keep the old versions intact so the users who have issues with the latest update can survive with the old ones. 

Or, at least they wouldn't force me to install the latest version at the login page. I find it very unfair and annoying becos I just know they'll give me problems with it. 

 

Share this post


Link to post
Share on other sites

Sorry, no.

I can appreciate that you have issues with your computer, but those issues are yours and yours alone.

Second Life is a living, moving world where development takes place constantly (by all sorts of people, not just LL). I think slowing down on development would harm more people, constantly waiting for the slow and lazy to catch up. Haha I think we all had enough of that in high school.

One of the recent updates turned my world pink, none of us are immune. Not many of us are world-class troubleshooters (yet!), and no-one forces you to update your viewer with EVERY new release. The difference is mostly the ability to keep learning, keep improving and keep working at making your - and everyone elses - SL experiences better.

Share this post


Link to post
Share on other sites

I understand your pain, im a mac user also, but it's gonna get worst before it gets better as the Lab move stuff around for major upgrades comming. Try deleting your cache to see if that improves anything. Also you can switch off automatic downloads in Options> Setup, switch to manual updates.

And also here is the beta page if you wonna try those out > http://wiki.secondlife.com/wiki/Linden_Lab_Official:Alternate_Viewers

Share this post


Link to post
Share on other sites

I'm not sure if you read my post carefully or not. 

I'm frustrated about this new update because it forces me to install the new version at the login page. 

If i can get away with it, of course I would overlook the new update and never bother anyone else about the following issues.  

And what a nice way to say it's my problem alone when some other people go through the similar issues (please google some of the issues aformentioned cos you'll find those easily) and I'm not just standing by my own, I have a number of friends in SL who have the similar issue, that's why I'm volunteering to write this post to find a reason why I (and we) keep having this issue within the new updates. 

I'm not ticketing this issue because I know LL is aware of it before I am. And I'm hoping they'll notice this small post and try to fix this for the next version. 

 

 

Share this post


Link to post
Share on other sites

 

Yeah I mean, I've done that also. 

Switch to manual updates, and it still forces me to install. I don't know why it won't allow me to log in without updating, and that was the first thing I checked. Do you have any suggestion what I should do? 

Share this post


Link to post
Share on other sites

Ya I read your post, your issue wasn't clear, neither was there any obvious action (I concluded you wanted LL to stop developing for some reason). Thanks for the bold bit though.

If you get an error when you try to login without updating your viewer, take a screenshot (redact any personal data) or copy the error message word-for-word.

The problem is assumed to be yours alone because turning on manual updates (as Loki describes) works. I have no experience with Mac's, but if you continue to have trouble then users here will need more to go on. As above, please post more information if you have it/want help.

Linden's don't read this forum.

Share this post


Link to post
Share on other sites

There was only one mandatory update to the SL viewer recently and that was a couple of months ago. It's possible something in your configuration files got corrupted when it tried to install and the system isn't recognizing your installation properly. I'm not familiar enough about Macs to tell you where to look for the configuration but someone here probably is.

As far as the graphics problems, do you by any chance have a Mac laptop that has automatic graphics switching between integrated graphics for low-power applications and a separate Nvidia or ATI/AMD graphics chip for graphics-intensive programs? There have been problems with SL thinking this type of computer only has the integrated graphics so the graphics won't run using the good graphics chip, which would result in low-quality graphics. Again, I need to defer to Mac experts for a work-around if this is the case.

Share this post


Link to post
Share on other sites

Most of the Linden people are Mac users too, so they also run into problems with some of the updates.  Unfortunately, updates are necessary, not just with Second Life, but with all things computer-based.

It's frustrating, but know we all go through periods of unrest. 

When you download an update, always remember to uninstall the previous version completely, to give it the best chance of working properly. 

Nothing in life remains the same. All is evolutionary. And we are all part of that evolution, so you are very much not alone.

Share this post


Link to post
Share on other sites

No. I'm 110% sure LL made this mandatory. Because the last time the update happened, i was be able to skip it as the pop up menu floated in my viewer where I could just click (x). And this time, nope.

Share this post


Link to post
Share on other sites

It seems like update is a ritual that I have to go through in order to enjoy the game, which is a huge letdown. 

Do you know what versions still keep up with the old graphic requirements?

I tried some of the old versions but I believe one time it worked, which was 3.3.1. I downloaded it and the graphic was back to normal but then i toggled with the preferences and it went right back on gritty ugly graphic once again, and unfixable ever since.

But it did work for me the last time. I downloaded an old version and worked like a charm so I'm still hopeful that this problem could get better without having me pay for the new graphic card that LL wants me to have. 

Share this post


Link to post
Share on other sites

Yes, support was dropped for some older viewers on this release and an update was pushed. This time around, Second Life Viewer 3.3.2 was removed from the supported list.

In the new viewer release, the graphics settings got a fairly large overhaul. It was needed because there is much more variety these days in what different cards can handle well (or at all), and because some high end features of a few years ago have moved to the lower and middle end on the latest hardware. The quality slider in the graphics settings now has 7 positions instead of 4, and the table of GPU chips was updated to use it.

Share this post


Link to post
Share on other sites

 

I'm afraid it's going to be trial and error to get a viewer that will work for you. On this machine - which is Windows Vista operating system - I get on best with an older version of Phoenix, or Imprudence. On my laptop, Firestorm latest version works really well.

Regarding needing a new graphics card, as long as you maintain an older one which you've been using to access Second Life, there isn't really any reason why you should need to replace it. Keep your system clean and well cleaned out, ensure you don't run too many programs at once, and also make sure you have plenty of RAM available (ie uninstall and delete anything excess on your hard drive on a regular basis).

Please try not to think of LL as the enemy. I don't believe they are intentionally trying to get everyone to upgrade their graphics cards, just trying to make SL work acceptably for the majority can be difficult.

And again, I do stress that we all go through periods when it feels like we are getting pushed out of SL because of some kind of technical hiccups.

Share this post


Link to post
Share on other sites

I can't speak about the latest round of updates because I haven't logged in for several months, but in the past the only reason why LL forced updates was to fix major, major problems. Most of them involved security holes, copybotting, sim crashers that ran older versions of the client, etc.

Whenever a mandatory upgrade is out, it unavoidably breaks things which they scramble to fix. Sometimes it's a few days, sometimes never.

My only advice is to cut your losses and move on to the next fad that will go horribly wrong.

Share this post


Link to post
Share on other sites

If you were on Viewer 3.3.2 you would have received a mandatory update.  Viewer 3.3.2 was several months old and was only continuing so long because of problems LL had with Viewer 3.4.

Share this post


Link to post
Share on other sites

Yea yeaaa please judge me for grasping on LL's viewer (haha)... I'm only using it because I'm so used to the viewer and I think it's quite convenient to keep up with the latest system in SL but again, LL forced me out of the usage this time so badly, I don't think I'll ever download their official viewer knowing the risk is at my cost. 

Share this post


Link to post
Share on other sites

Yeah, I can understand the reason behind their changes, but cmon, such drastic shift of the graphic cards doesn't make sense to me at all. Isn't it supposed to be user friendly? Esp, when they build this thing on Mac and knowing its graphic card can't be easily replaced to the other. I really don't see the point of even having the download factor for Mac users in the first place when they're going to create problems like this. And I'm not alone with this thing. 

Share this post


Link to post
Share on other sites

Oh yeah I'm sure they try their best to fix the major issues in SL, and I'm very happy about that. But now that they forced me to update my viewer to bork my graphics in the game, I can't even use the official viewer anymore. I'm forced to use 3rd party viewers though their attempt to make this better. I guess their priority is to fix problems than to create more users who can't afford the new graphic cards. 

Share this post


Link to post
Share on other sites

Oh no, I don't even think of them as an enemy. I love Second Life and I think it's the best virtual game there is. I'm just complaining about this particular update because it changed my whole experience in SL. I had a good time enjoying the high quality photography and so many other options, graphic wise, and just one update it took and I can't bring it back. So I'm just wondering why they had to shift this to the other. 

I'll just stick to the 3rd party viewers now like the old generation in SL. 

Share this post


Link to post
Share on other sites

Be careful ... going the way of the oldbies has been clinically proven to cause people to buy Joan Rivers jewelry from infomercials, buy the Sham-wow, and randomly shout, "get the hell off my lawn, you young whipper snapper!"  :matte-motes-bashful:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...