Jump to content
Sign in to follow this  
BlackHeaven1983

Why does my mesh look inside out?

Recommended Posts

I'm using 3dsmax 2012.   

Most the time when I upload a mesh, it appears inverted inside SL...as if the normals are flipped....

I've tried selecting the polygons in 3dsmax and flipping them while in edit mesh mode...and i've tried using a Normals modifier to flip them....and everytime I upload the mesh, it still looks inverted.  Any ideas?? 

 

Side note...  this only happens after i've reset the xform.  However i have to reset the xform in order to get the mesh to upload AT ALL cuz SL doesn't like transform modifiers.  

Share this post


Link to post
Share on other sites

You can change the normals after using your XForm modifier. I'm not sure what causes your problem, but you can select "backface culling" in object or layer properties to show only the positive side of the faces, like in SL.

btw, which dae exporter are you using?

Share this post


Link to post
Share on other sites

Yes, but the normals don't seem to be the issue.  They look fine inside 3dsmax.  And i've even inverted the normals the wrong way, and it makes no difference to the model in SL.  So I don't know that the problem is the normals for sure....what else could it be though?

Oh, and i'm using the fbx exporter, then using the stand-alone fbx convertor to make the file a dea.  I've done several uploads before that work.  The inverted issue only happens after i've used xform on some meshes.  And I know the xform can invert the normals, however as I said, the normals are all flipped the correct way.

Share this post


Link to post
Share on other sites

OK....well....I had some success!  Though I don't understand why...   I used a Normal modifier before in order to flip the normals the wrong way and it was still inverted in SL.  ....however....adding a normal modifier, and turning OFF the "flip normals" option (so it doesn't change anything) seems to make it work...  I don't know why, or understand it at all...cuz technically it shouldn't be changing anything....but it WORKS.  And that's all I care about :)

Share this post


Link to post
Share on other sites

If this is what i think it is, I get this all the time at work.

Basically what causes this in Max is when you model half your mesh, mirror and combine both halves to make the whole. It doesn't show in the Max viewport but the normals are inverted.

The solution to this is, activate backface culling. Then when you attach the mirrored half, Reset xform the model. You'll probably see the normals flip. Apply a normals modifier, collapse all again. And it should be ok. Personally I like to spam the reset xform a few more times and recollapse to be sure. I've actually had models that didn't reset correctly on the first try.

It's been like this for as long as I can remember.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...