Jump to content
Sign in to follow this  
Anakin Crystal

3DS Max 2011 help with the maps

Recommended Posts

HI again, thanks to those that have helped me, but my question is now.. is the diffuse maps and the ao maps..

I use 3ds max, i can bake the shadows on a ao map and upload fine...but when i use the diffuse map in 3ds max its all **bleep**ty and mesed up

Yes, i did uv map it and i also use automatc mapping when i render to texture.. on the current channel.. as i see at time my channels change usually 1 - 3 , never understood that fully either...

But my main problem is the diffuse map .. and when you apply a bit map to a ao it doesnt show up when you bake it

- Anakin -

Share this post


Link to post
Share on other sites

Can you post a picture of your bleepy and messed up texture? I suspect it is because you render on channel 3 while the UV mapping is done on channel 1, but I'm not sure.

Anyway, why bake a diffuse map in the first place? Best case scenario is you get your original diffuse bitmap back.

Share this post


Link to post
Share on other sites

What do you mean by AO map exactly. Are you rendering AO using the render surface map feature or do you have AO enabled in a Mental Ray material? If using render surface map you'll want to take the grayscale image it generates into an image editor to clean it up and combine it with your texture map.

When you bake maps using render to texture Max by default will apply an automatic unwrap on a new UV channel. If you've manually unwrapped the UVs you want it to use that instead of doing an automatic unwrap. Be sure to set RTT to use the correct UV channel.

As for your diffuse map troubles you need to give more information. What material type are you using and how do you have it set up and which renderer?

Share this post


Link to post
Share on other sites

  when i use a diffuse map when i render to terxture using diffuse map.. it doesnt  show up right if you find me inworld i can show you... my name is anakin crystal as for the channels i will make sure the channel is at 1 

Share this post


Link to post
Share on other sites

But if you dont know what im tryin to acheive is  upload the texture with shading  just like you do it in the ambient occulsion.. but as you said i need to mix the ambient with teh  diffuse..?  cuz i can upload the ,tga  with ao map with perfect  shading..  but when i use the diffuse map it doesnt line up right.. 

Share this post


Link to post
Share on other sites

To get the fully shaded texture including shadows and specular highlights using Render to Texture you need to render out a "Complete Map" rather than a diffuse map. Rendering a diffuse map out of RTT is only useful as a layer for compositing. If you want ambient occlussion as part of your complete map you either need to use a material that generates it (like the Mental Ray Arch&Design material with AO enambled in its advnaced effects rollout), or if you're using the scanline renderer you need to render an Occlussion Map seperately with Render Surface Map and combine it with your complete map in photoshop.

Share this post


Link to post
Share on other sites

Hi guys.. thanks you for your recent help...as i have followed what you have said but somethin is still not right i have upload the following screen shots  showing a stucco texture appllied . Using the material editor in that roll out is the diffuse and bitmap.

http://i1147.photobucket.com/albums/o548/Anakinsw2010/3ds%20max/bitmap.png

 

The second and third describes my rollout.. 

 

http://i1147.photobucket.com/albums/o548/Anakinsw2010/3ds%20max/rtt1.png

 

http://i1147.photobucket.com/albums/o548/Anakinsw2010/3ds%20max/rttcomplete.png

 

Ok..in my final render..it looks great here it is 

 

http://i1147.photobucket.com/albums/o548/Anakinsw2010/3ds%20max/rttstucco.png

 

Ok now when i apply the final rendered texture in SL it looks like this ... 

 

http://i1147.photobucket.com/albums/o548/Anakinsw2010/3ds%20max/diffusemapwithbitmap_001.png

 

I did use the " complete map " 

 

Thanks

 

Share this post


Link to post
Share on other sites

Did you uncheck the "automatic unwrap"  like Chip suggested?

As far as I can see it's still active. It's checked in your RTT rollout and the unwrap shows in the modifier stack after RTT.

What I think is happening is the RTT is making a new UV layout on the same channel you used for your own UV.

If you either use the exsisting UV for RTT or export your model after you did the baking, everything should be fine then.

 

*edited some confusing typos

Share this post


Link to post
Share on other sites

One or two things happened there. When you use RTT it by default will do two things you probably don't want. First it will add an automatic unwrap to your object on UV channel 3, and second it will take the resulting baked texture and assign it to a new material, replacing the material on your object and with the new bitmap set to use UV channel 3. At the top of the RTT dilaog make sure it's set to use the existing UV channel (1). If it previously added an automatic unwrap modifier to your object, delete it from the modifier stack. At the bottom of the RTT dialog check the box for "Render to file only" if you don't want it to create a new shell material and would rather set up the new material yourself.

Share this post


Link to post
Share on other sites

I did everything like you told me...this is my result... 

 

http://i1147.photobucket.com/albums/o548/Anakinsw2010/3ds%20max/rtt-try2.png

 

This is what happened when i appl;ied it to the object

 

http://i1147.photobucket.com/albums/o548/Anakinsw2010/3ds%20max/secondtry_001.png

 

http://i1147.photobucket.com/albums/o548/Anakinsw2010/3ds%20max/secondtry_002.png

 

 So...now i dunno what to do now...

Share this post


Link to post
Share on other sites

In your screenshot you have RTT set to use existing channel 3 instead of 1. I'd add an unwrap UVW modifier to your object set to channel1, open the UV editor and make sure the UVWs are how you want them. Once they are collapse the modifier stack. Then apply your material and rebake the texture making sure RTT is set to use existing channel 1 (the little dropdown menu to the right of the "use existing channel" toggle), and that it's set to render to file only.

Share this post


Link to post
Share on other sites

Wow! Thanks... chip, i owe you LOL!...only issue was  when i used a .tga format i was seeing thru it... so i did ise a jpg format that was better. 

 

Another question., how do i make the shadow darker , when i enable the shadows function, when i use skylight? 

Share this post


Link to post
Share on other sites

Hi, I have a question related to RTT in Max, so will post here to save starting a new thread. 

I want to be able to bake a texture that results in my shadows starting from black and fading into transparency. At the moment my shadows start from black and fade into white. I would also like the background of the texture to be transparent too. Is there any way to do this in the RTT process?

If not is there anything I can do in Photoshop with my baked texture so I just end up with shadows fadding into transparency.

Thankyou.

Share this post


Link to post
Share on other sites

Anakin Crystal wrote: Another question., how do i make the shadow darker , when i enable the shadows function, when i use skylight? 

Since a skylight emits an even amount of light from every direction it won't produce strong shadows on objects without areas of strong occlussion. You can make the light a bit more dirrectional by using a gradient ramp in the skylight's map slot.  Or just add a directional shadow casting light to the scene and adjust the light's shadow density to your liking. You could also render a seperate shadow or occlussion pass and do the composite in photoshop where you can adjust the levels on the shadows.

Share this post


Link to post
Share on other sites


Swobbly Minogue wrote:

Hi, I have a question related to RTT in Max, so will post here to save starting a new thread. 

I want to be able to bake a texture that results in my shadows starting from black and fading into transparency. At the moment my shadows start from black and fade into white. I would also like the background of the texture to be transparent too. Is there any way to do this in the RTT process?

If not is there anything I can do in Photoshop with my baked texture so I just end up with shadows fadding into transparency.

Thankyou.

I'm not sure how you could do that with RTT since a transparent object wouldn't actually produce shadows. What you could do is take that grayscale shadow pass into Photohop and use it as a layer mask to control transparency.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...