Jump to content
Sign in to follow this  
Mac Shoreman

"Second Life: Link failed -- Unable to link any pieces - pieces are too far apart."

Recommended Posts

2 prims positioned in exactly same x, y & z coordinates in world.

Prim 1:

  • Sphere
  • x, y & z dimentions 3.5 meter

Prim 2:

  • Cylinder
  • x & y 4.75 meter and z 0.12 meter.
  • Hollow 70 %

Same error in all wievers I tried "Second Life: Link failed -- Unable to link any pieces - pieces are too far apart."

Spent 2 hours on this issue and in 4 sims. Any sugestion to whats up THIS TIME with SL? Geting soooo tired...

Share this post


Link to post
Share on other sites

I had this happen yesterday with small, but not nano, prims that were actually touching each other.  Yet a friend standing next to me with my mod rights was able to link them.  They were well within the linking rules. Relogging didn't fix the issue. However later in the day there was no problem. 

In addition to this I had spontaneous permission changes too.  A multi prim HUD I owned and created that I was working on suddenly changed from full permission prims so that I had copy only permissions on some of the prims, transfer only on others.  I had to rebuild the entire item.

After these incidents there was unplanned inventory server maintenance.  My sim also had the scheduled deploy yesterday,  so I suspect a bug.  I haven't tried to build yet today, but hopefully won't run into either of these problems.

Share this post


Link to post
Share on other sites

Just a few things to consider before you throw your laptop through the window.

 

  • Sometimes ... especially if you use a "drag select" to select your prims ... you can include one or more objects in your intended link that may not belong to you. If you try, you get a failed link message, Depending on where you are working, this could be an object (prim) underground, behind a wall, invisible, anywhere in the background in your view. - In your build options be sure to check "select only my prims" (what ever it says) this prevents selecting a non-owned object in the background in a drag-select. If you are only trying to link two objects, try selecting one object by clicking on it, then [sHIFT] + click to select the second object.

 

  • Another possible reason: you are working in "edit linked" mode. This mode will not allow you to create new links, and a common oversight not to turn this off before attempting to link objects

 

  • This may seem rather self evident, but I mention it just to help you sort out the problem from all aspects. If one of the objects was not your creation originally and has been marked "No Modify" you can not link it to anything else. Both objects must be modifiable.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...