Jump to content
Sign in to follow this  
Oskar Linden

Deploys for the week of 2012-10-15

You are about to reply to a thread that has been inactive for 2814 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Thanks to everyone who participated in the Network Pile On Test last week. The code from that test will be on BlueSteel this week. If it passes the simulator smoke test that is.

 

Second Life Server (main channel)

We are promoting the code from BlueSteel to the main channel this week.

 

  • Backend fixes to improve database access for large groups.

 2012-10-16, 5:00am: Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Server/12

  

Second Life RC BlueSteel

This is a maint-server project. There are no simulator changes. It's all back-end infrastructure work.

2012-10-17, 7-11:00am: Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_BlueSteel/12

 

Second Life RC LeTigre

This channel has updates to Havok among other things including bug fixes. Details soon.

2012-10-17, 7-11:00am: Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_LeTigre/12

 

Second Life RC Magnum

This will have the same code as last week. It will be merged with the code from trunk. There WILL BE a rolling restart.

This is a maint-server project.

  • Bug Fixes
    • Back end infrastructural changes.
    • No intentional change to behaviour.

 

 2012-10-17, 7-11:00am: Release Notes: https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Magnum/12

We will be monitoring this thread during the next week so please feel free to post issues that you feel have been introduced by the new code. Please file a JIRA for issues you find and post the JIRA link into this thread. It really helps us out. When determining if issues are relevant or not research is key. Tracking down exactly the right situation where an issue is occurring greatly speeds up the development process to get fixes in place.

I appreciate your help. Have a good week!

 

__Oskar

 

p.s. If you are interested in helping test SecondLife in beta please join the group "Second Life Beta" in-world. We also have an email list where we communicate upcoming projects and how you can help. (https://lists.secondlife.com/cgi-bin/mailman/listinfo/server-beta ) Once a week we meet on ADITI to discuss new features, new bugs, new fixes, and other fun stuff. You are more than welcome. Information is here:https://wiki.secondlife.com/wiki/Server_Beta_User_Group

 

This is not a forum thread for off-topic and unproductive ranting. I will no longer tolerate it. This forum thread is to discuss newly found issues in the Release Candidate channels. If you feel the need to have your opinions heard on topics unrelated to new bugs then please start your own thread. If an individual continues to post unproductive and off-topic comments I will take measures to remedy that.

If you are unsure about your posting please read this : "Linden Lab Official:Community Participation Guidelines"

Share this post


Link to post
Share on other sites

My home sim Mahalo Pacifico has been down 3 hours now...something is wrong..SL just logs me out when I try to go there.

Jira filed 90 min ago...also Mahalo Beach seems to have the same problem...Mahalo and Mahalo Harbor restarted and returned to service fine.

Share this post


Link to post
Share on other sites


Justyn Andretti wrote:

OK its 10-16-12 - 10:20am EST  and I can't login says UNABLE TO CONNECT TO SIMULATOR....

You unable to connect to simulator? Oh dear. Is everything fine almost two hours later?

Share this post


Link to post
Share on other sites

Hello Oskar,

No restart for Magnum?
Are the updates for the main channel not merged into Magnum and the other RC's?
Magnum is now two weeks behind the main channel.

Greetings, Chriss.

 

 

Share this post


Link to post
Share on other sites


Justyn Andretti wrote:

OK its 10-16-12 - 10:20am EST  and I can't login says UNABLE TO CONNECT TO SIMULATOR....

This means that the Simulator you are trying to get to is still down, try logging into Pooley or Smith and that should get you into SL at leat. HTH. 

Share this post


Link to post
Share on other sites


Chriss Rosca wrote:

Hello Oskar,

No restart for Magnum?

Are the updates for the main channel not merged into Magnum and the other RC's?

Magnum is now two weeks behind the main channel.

It will be. That was my mistake. Correcting it now.

__Oskar

Share this post


Link to post
Share on other sites

Two Magnum regions I monitor have had restarts (apparently two crashes each at least) in the last hour. They now are experiencing issues with HTTP and email in and out failure, object rendering and updating failure (attached and rezzed), capabilities for agents failing as well (can't access about land parameters). Just a heads up.

Now seeing an issue with agents ghosting when attempting to leave these regions.

Share this post


Link to post
Share on other sites

You are at 282,068.0, 258,382.0, 75.6 in Ratmaw located at sim8663.agni.lindenlab.com (216.82.39.222:12035)
Second Life RC LeTigre 12.10.12.265819
Error fetching server release notes URL.

The region is showing as off-line (red on map) but I am here!  There is a sim next to this one which is showing as online on the world map but is not there. Gingivere - no idea if RC channel.

 

Black

 

[Edited to add - cleared cache and the region appears to be there now, will do that first in future! )

Share this post


Link to post
Share on other sites

Black

What you saw (I think) is the maps lagging behind the true state of SL.  I saw it today as well, but I have seen it before so I'm not that concerned.  It may be that the lag was a bit more pronounced during the roll I don't know.

There seems to be an accessibility and visibility issue with diagonally adjacent sims, but this is down to the software running on Main Server sims I believe.

Share this post


Link to post
Share on other sites

Thanks Ayesha - I figured I must have broken something when I saw green dots appearing on the world map but not showing on the mini map - the region was still not showing to my viewer when I stood on the boundary either before the cache clear...  I'll clear the cache first next time :matte-motes-big-grin-wink:

Share this post


Link to post
Share on other sites

Hi Oskar,

Just out of curiosity why are the Magnum servers getting a second restart today? Mine restarted this morning(Wed) and have had no reports of anything being out of order in fact it's been running pretty good :)

Thanks :)

 

Rolling Restarts for Magnum RC Channel
http://status.secondlifegrid.net/2012/10/17/post1796/
[Posted 2:40pm PDT, 17 October 2012] We will be performing rolling  restarts for regions on the Magnum RC server  channel. They will begin tonight (Wednesday, October 17th) at approximately 5:00PM PDT. Please refrain from rezzing no copy objects, making inworld  L$ transactions and remember to save all builds.

Share this post


Link to post
Share on other sites

Hi MB, the server version deployed by the roll to Magnum this morning was missing a small change. The version planned for today's 5pm roll to Magnum includes that change, but is otherwise identical to what was deployed this morning.

 

In other news, I have posted the release notes for this week's RC updates:

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Magnum/12#12.10.12.265826

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_BlueSteel/12#12.10.12.265813

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_LeTigre/12#12.10.12.265819

Share this post


Link to post
Share on other sites

The sim crossing between two LeTigre sims appears to be noticeably worse for ground vehicles than it has been. They aren't failing but it looks like it's about twice as slow as the main channel for anything with any complexity. Prim and mesh vehicles act the same. Air vehicles don't seem to be affected. I couldn't test water vehicles because LeTigre Sandbox 4 is down.

Share this post


Link to post
Share on other sites

And some brain-dead pillock of a Linden seems to still think it's OK to block the ANWR channel with a single region running the new Havok code (Region Sandra), Likewise the waterway north of the Color regions (Region Hildegarde) You can add Region Maroon to that list of idiocies.

Just what is it that you are trying to test? New physics code, or sim-crossing?

 

Share this post


Link to post
Share on other sites

One of my regions, on LeTigre, was crashing several times a day.  Yesterday there was 8 server crashes I could account for.  I ended up contacting concierge support to have my region set to the SL stable main channel and haven't crashed since.  The service rep informed me she had just handled a different case on LeTigre where 64 crashes/restarts were found in the crash logs.  

I'm not sure if this has to do with the new Havok engine, or something else, but since I've been off LeTigre everything has been up and running with no server crashes.  Has anybody else noticed anything like this?

Share this post


Link to post
Share on other sites

Would you please fix the crash followed by region is logging you out bug that apparently was introduced again in last weeks restarts.  Also try to do something with the debilitating memory leaks and lag in the servers which are still clogging our cpu cache and causing problems, as well as using current saves rather than ones from previous weeks for the restarts, since those reintorduce problems that have already been fixed by LL or the players. 

Share this post


Link to post
Share on other sites


Lydia Craig wrote:

Would you please fix the crash followed by region is logging you out bug that apparently was introduced again in last weeks restarts.  Also try to do something with the debilitating memory leaks and lag in the servers which are still clogging our cpu cache and causing problems, as well as using current saves rather than ones from previous weeks for the restarts, since those reintorduce problems that have already been fixed by LL or the players. 

Will you please stop being clueless?

 

Share this post


Link to post
Share on other sites


Perrie Juran wrote:

Lydia Craig wrote:

Would you please fix the crash followed by region is logging you out bug that apparently was introduced again in last weeks restarts.  Also try to do something with the debilitating memory leaks and lag in the servers which are still clogging our cpu cache and causing problems, as well as using current saves rather than ones from previous weeks for the restarts, since those reintorduce problems that have already been fixed by LL or the players. 

Will you please stop being clueless?

 

Be nice Perrie.

 

__Oskar

Share this post


Link to post
Share on other sites


Oskar Linden wrote:


Perrie Juran wrote:


Lydia Craig wrote:

Would you please fix the crash followed by region is logging you out bug that apparently was introduced again in last weeks restarts.  Also try to do something with the debilitating memory leaks and lag in the servers which are still clogging our cpu cache and causing problems, as well as using current saves rather than ones from previous weeks for the restarts, since those reintorduce problems that have already been fixed by LL or the players. 

Will you please stop being clueless?

 

Be nice Perrie.

 

__Oskar

My apologies Oskar.

 

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 2814 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...