Jump to content

Please help me fix camera movement!


sunnygirl OHare
 Share

You are about to reply to a thread that has been inactive for 3055 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I hadn't logged into SL for awhile, so I had to update it (ofc). After restarting it, I clicked my avatar to move the camera and a hand pops up and the camera goes in the opposite direction that I want it to go to. I looked for an "invert" or something option...but I'm finding nada. 

 

This is really frustrating because I feel like I can't even move my avatar. Which kinda defeats the purpose of logging in at all. :( Can I change this back to how it used to be?

 

Edit: Ok....I found the "invert" tick box....but it's not changing how the camera is controlled. I like to use the mouse left click and drag to look around (like the MMO's I play) and this is seriously not working. Why is that little hand even there? :(

Link to comment
Share on other sites

The camera controls, or to be more accurate avatar moving via clicking avatar, holding in and moving mouse to steer, have changed on the latest LL viewer

The only reasons you would think they have not is you must not use the v2/V3 LL viewer, but a V1 based viewer.

To the OP, yes you are correct.  You need to discard the LL viewer, and use Nirans or Firestorm, and avatar will move as you are used to.  For some reason these controls are all to hell on the LL viewer.  Surprise surprise.

Mind you, you missed a treat, as it seems you were fortunate to miss the first V2 shambles of a viewer.  The latest V3 LL viewer is a huge improvement, but still poor vis a vis Firestorm and Nirans, especially.

I wonder if heads ever did roll for that initial V2 mess?  Knowing LL, probably not.  The guilty party/parties probably got a raise.

 

Link to comment
Share on other sites

The feature you've enabled is called 'Click to Walk', the idea is to reproduce the style of movement popular in many MMOs.

To disable Click to Walk (in any viewer):-

  • Be sure you can see the Advanced menu at the top (V1: Ctrl + Alt + Shift +D, V2/3: Ctrl + Alt + D to display it)
  • Advanced > Show Debug Settings
  • In the Debug Settings box enter the text 'ClickToWalk' (without apostrophes).
  • Set it to FALSE.
  • Click OK.

 

And go back to controlling SL as you prefer.

Link to comment
Share on other sites

Thank you Freya and Hitomi! I thought that option was a little freaking weird! lol

 

To Sigren, I happen to like the SL viewer. I've tried the others in the past and they had a clunky feeling to them for me. I assumed if I used it long enough that I would have gotten used to it, but I like the SL viewer, so why bother. Thank you though. 

 

 

Link to comment
Share on other sites

  • 2 months later...

Yeah the camera movement is just ridiculously awful compared to normal mmo games out there. In SL, a hand pops up when I want to move the view around. Then I panic and try anything but things don't work like I have used to. In other games, everything just works fluently as I have used to. I think this camera view thing is one issue that put people off from SL, so it should be fixed. Yes, fixed. It is not working as expected even though you think it is just fine. I didn't like it couple of years ago, and now I have played tons of other games, and tried SL again, and oh the horrible clumsyness struck me sooo hard!

Link to comment
Share on other sites

  • 5 months later...

i am using the most recent update to firestorm but my cam is acting odd. everytime i go to move, the camera moves overhead so i am looking almost straight down when move even though have rear view selected. I tried adjusting the angle in preferences but as soon as i moved, it went back overhead. please help me fix it.

Link to comment
Share on other sites


MattInAe Landfall wrote:

i am using the most recent update to firestorm but my cam is acting odd. everytime i go to move, the camera moves overhead so i am looking almost straight down when move even though have rear view selected. I tried adjusting the angle in preferences but as soon as i moved, it went back overhead. please help me fix it.

I suggest you look at the Firestorm help pages and if you cannot find the help there, file a support ticket with them.  They are usually very helpful.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3055 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...