Jump to content
Sign in to follow this  
Oskar Linden

Deploys for the week of 2012-10-01

Recommended Posts

Oh well, I've just put everything back by hand. Hopefully that'll all vanish, otherwise the parcel really will be too full :matte-motes-wink:

Share this post


Link to post
Share on other sites

Hope things are cleared up as fast and as well as you can. Alot of tenants are reporting in of missing items. breedables , homes, furnishings etc.  Would be good to send a link for people affected to list SIM name and parcel Slurl perhaps to better help those who may feel lost in the 'wash' ? on the Dashboard  or Gridstatus maybe ?

Share this post


Link to post
Share on other sites

Oskar

Well, this is a fine old mess.  First  roll borks scripted objects.

Second roll seems to have put everthing back as it should be.  I log off for my dinner.

When I relog (just now) I discover that my account has been reset.  My viewer is on default settings: ALL default!

Then while I am working to figure out what has happened the sim restarts again.

What on Earth are you guys doing??

And this is code that passed QA?  Do you really expect folk to believe that?

 

PS: I'm not an ungrateful brat, I know the support and release teams will be working their asses off to get this mess straight, and I very much appreciate the amount of communication you have given us, Oskar.  It is just a shame that you have had to work so damned hard to correct the effects of what must have been shoddy QA.

Share this post


Link to post
Share on other sites

Oskar Linden says: "The second step is to restart the region to a simstate that was before the prims got returned. It is a process that is done by hand. There is no way to automate it."

Hire me.

I'll make a way to automate it.

I'm sure there are about a dozen million other people who could automate a rollback from a *release candidate* software rollout as well.

Any of those people could also make a few reasonable suggestions about how to write regression tests.

Share this post


Link to post
Share on other sites

Hang in there Oskar ... the day is almost over. Some work days are just not a lot of fun. I think that's why they call it work; a 4-letter word by the way ;-)

Share this post


Link to post
Share on other sites


Solo Mornington wrote:

Oskar Linden says: "T
he second step is to restart the region to a simstate that was before the prims got returned. It is a process that is done by hand. There is no way to automate it."

Hire me.

I'll make a way to automate it.

I'm sure there are about a dozen million other people who could automate a rollback from a *release candidate* software rollout as well.

Any of those people could also make a few reasonable suggestions about how to write regression tests.

"There is no way to automate it" given the time that we had. It is technically possible to automate, but we don't currently have a system for it. Most simstate rollbacks are one offs and don't need a massive level of automation.

__Oskar

Share this post


Link to post
Share on other sites

I have filed a ticket on problems on our homestead Fourier - The particles of a fireplace in a Brennan home do not function correctly. The water spray of the water fountain on the home barely is visible anymore. Same house I rezzed on a sandbox sim Aldora works normally at that location. Also noted that anything that uses particles - Fire, Water spray, BDSM furniture to rez chains, and poofers or other environmental items are failing  to function normally and restarting the sim from the estate manager console does not help the issue. I filed a ticket on this 2 days ago via the help desk support - no reply thus far.

 

Question - when will this be fixed.

Also I have noticed if you near the sim edge in any vehicle like a boat or hangglider you can get sucked into basically a whirlpool like spin which you are unable to come out of with the vehicle and have to abandon the vehicle to gain control of your avatar again. Something in the recent changes is causing several issues - which basically set users ability on vehicles and particles rezzer to malfunction or not work at all.

 

 

 

Share this post


Link to post
Share on other sites

I'm not sure if this is related to the messed up roll but I'll post it here anyway in case it is:

I'm trying to buy things from market place as a gift, yesterday they got stuck waiting for delivery and ended up being refunded from sl communication timeout, one hour ago I tried again and again the items are left pending delivery, I checked the stores to make sure there is an active magicbox and in both stores there was.

Any ideas?

Share this post


Link to post
Share on other sites

... anything that uses particles - Fire, Water spray, BDSM furniture to rez chains, and poofers or other environmental items are failing  to function normally and restarting the sim from the estate manager console does not help the issue. I filed a ticket on this 2 days ago via the help desk support - no reply thus far.

This is a viewer problem. I noticed it, too--coincidentally on a rolled-back LeTigre sim, but it went away completely when I tried with a Snowglobe-based viewer (an ancient Phoenix version). I suspect it's another effect of a known, fix-pending viewer bug that was also visible at the same location, but only in relatively recent viewers.

Share this post


Link to post
Share on other sites


Lynna Yorcliffe wrote:

I have filed a ticket on problems on our homestead Fourier - The particles of a fireplace in a Brennan home do not function correctly. The water spray of the water fountain on the home barely is visible anymore. Same house I rezzed on a sandbox sim Aldora works normally at that location. Also noted that anything that uses particles - Fire, Water spray, BDSM furniture to rez chains, and poofers or other environmental items are failing  to function normally and restarting the sim from the estate manager console does not help the issue. I filed a ticket on this 2 days ago via the help desk support - no reply thus far.

 

Question - when will this be fixed.

Also I have noticed if you near the sim edge in any vehicle like a boat or hangglider you can get sucked into basically a whirlpool like spin which you are unable to come out of with the vehicle and have to abandon the vehicle to gain control of your avatar again. Something in the recent changes is causing several issues - which basically set users ability on vehicles and particles rezzer to malfunction or not work at all.

 Ok I may be way off base with this but I've had this issue in the past & also on the edge of my sim.  Was caused by a mega prim textured with a scupt that neighbor was using for wall.  The bounding box kept boats from work properly & they would as you say, get sucked into some kind of vortex and spin.  And that was only if you were able to actually get the boat funtioning to begin with. 

Anyway, just a thought.

 

 

 

 

Share this post


Link to post
Share on other sites

Oskar,

Thanks so much for spotting and fixing the LeTigre issues yesterday. I'm sure that was not how you expected your Wednesday to go.

Any possibility on a post-mortem on the issues that cropped up?

Share this post


Link to post
Share on other sites

I don't have a Le Tigre or RC sim so I don't know if this is where to report this issue or not, but I just discovered, to my very great horror, that my subscriber kiosk where my customer list is stored has vanished from inworld. I had not backed it up as often as necessary and so am missing about 1000 names.

In the inworld concierge group I have heard other reports of objects vanishing. My manager said an object she was moving vanished.  I was not concerned because I have copies of things in my inventory -- but forgot about this kiosk.

 

I am sick. Anyone else experience this or know what to do?  I resarted the region, did area search, filed a ticket. I guess I will make a bug report.

Share this post


Link to post
Share on other sites

... I resarted the region, did area search ...

Did you check Top Scripts to see if it's on the sim anywhere? I suppose it's unlikely, given that you tried the area search, but it would be a happy outcome if it showed up on the list.

(You also mentioned a report of an object going missing while being moved. If there's any chance that it bumped up against the sim border, I'd suggest doing a careful search of the sim at altitude 256. I know that doesn't make any sense, but numerous times, I've had stuff magically transported to that height when they hit a sim border in the build tool.)

Share this post


Link to post
Share on other sites

Thanks for the suggestions Qie -- a search of Top Scripts does not show it, and it is not at 256. Just gone.

I wish when I heard of others discovering things vanishing -- sometimes before their eyes -- it had dawned on me to back that subscriber up. 

 

I have requested a roll back -- well, more like begged for one, as I have not changed anything on that sim since I last used the subscriber.

Share this post


Link to post
Share on other sites

They rolled back as far as they could, to the 4th, and there was my kiosk.  I still don't know if that says anything about any particular deploy but something has been causing things to vanish lately, and not just mine. Not sure whether to file a bug report or not.

Share this post


Link to post
Share on other sites

We lost a whole tower, a tower top and a couple of small items on one day a month ago - maybe these paranormal occurences will increase as we approach Halloween, or maybe it is just a bug.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...