Jump to content

Make Firestorm run better!


You are about to reply to a thread that has been inactive for 2267 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hi guys I'm hoping I can get a little help here, I'm running a rather old pc yes but it was working really well on Second Life until recently, now sometimes I'll get a sudden burst of lag while trying to cam around or trying to move. I don't really understand it as it can happen in what I'd imagine are low lag areas.

 

My PC Specs are this!:

CPU: AMD Phenom(tm) 9500 Quad-Core Processor (2210.23 MHz)
Memory: 3072 MB
OS Version: Microsoft Windows XP Service Pack 3 (Build 2600)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce 8400 GS/PCIe/SSE2/3DNOW!

Windows Graphics Driver Version: 6.14.0013.0142
OpenGL Version: 3.3.0

 

I've considered installing a old firestorm viewer but then I have problems with trying to teleport. I'd really appriciate any help here.

Thanks!

Link to post
Share on other sites

I had  old computer for years then I bought a new one (about a year ago).

 I find SL at times to do all the same things you speak of (lag spikes crashing and so on ) at times and other  it runs 100%  ok  and this was and is on both my old and new computer .

As a person with a back ground in software it just tells me it's most  likely on the service side of SL and or possible my ISP  not my viewer or computer.

I also gave up using 3rd party viewers years ago after emerald made us all part of their DDos attack plan and I do not trust  16 year olds ( a few of the devs in the current 3rd parties ) with a program installed  on the same computer I do my banking on,I am  sure that is just me  but to each their own.

Link to post
Share on other sites

Both lag spikes and teleport problems are signs of an erratic connection. What kind of internet connection do youhave? SL needs consistent 2-way communication rather than pure speed.  Try going to "pingtest.net" and testing your connection to San Francisco.

Link to post
Share on other sites

I think using Phoenix is just going to make your performance worse.  Everyone that I know who is running XP and switched to Firesotrm from Phoenix has told me they get better performance.

Look at your internet connection.  If your using high speed broadband and you are using a wireless connection between your computer and modem, switch to use a cable if possible and you will probably get much better results.

Link to post
Share on other sites

lol I know my card is very old but I can't afford a new one right now. I'm looking into upgrading once I start working again.

My internet is through Virginmedia. I'm in the UK and I run on a 4mb speed which I checked on Speedtest and I cannot get higher than that (did check with company) the area I live in has no cables underground and they don't plan to add any soon, so I'm stuck with it down my phoneline. I just did the ping test from where I am in the UK to San Fransisco and it pinged at:

O% Packet Loss

482 ms Ping

33 ms Jitter

I have no clue what all that means lol, so is that good or bad?

Oh my interet is connected through a cable as my pc doesn't have a wifi connection. So I use ASDL.

Link to post
Share on other sites

Your ping is kind of high, but I've seen much worse out of the UK.

The problem is, LL isn't very good at making optimized software like other companies with 3D content (games, AutoDesk, etc.), and to make it worse, much of the content is created by people who barely have any idea what they're doing, adding to the issues.

It means if you don't have a computer that has insane horsepower to overcome it all, there's always going to be issues at times.

That said, there are things you can do to improve it. Make sure nothing else is sharing bandwith while you're on SL, close down background programs, all those little tips that normally sound really stupid and annoying.

Link to post
Share on other sites

I used to love Firestorm and it gave me great performance. When it became mesh enabled I found it was so slow for me it was unusable. I got a brand, new powerful computer and Firestorm was still slow for me with only 8 fps. I switched to the official Linden Viewer 3 and instantly got fps of 70 or more and with high graphic settings I now rarely experience lag. There seems to be too many lag inducing bells and whistles with Firestorm now and you may find by switching to V3 that you get better performance.

I tested most of the 3rd party viewers and found that the more features and toys they had the slower they were. Try and see....

Link to post
Share on other sites


Ziggy Starsmith wrote:

There seems to be too many lag inducing bells and whistles with Firestorm now and you may find by switching to V3 that you get better performance.

I tested most of the 3rd party viewers and found that the more features and toys they had the slower they were. Try and see....

I haven't found that the "bells and whistles" in Firestorm slow it down.  When I compare Linden Lab's V3 viewer and latest Firestorm (4.1.1) I get very similar performance on both.  Excellent framerates in both with high graphics settings. Even with shadows on gives very usable performance.  Only some rare occasional crashes, CPU usage around 12 percent.

 

Then again, I have heard about cases with very similar hardware as mine that for some reason the framerates are not so great in Firestorm.  Which is strange.

System info:

CPU: Intel® Core i7-2600K CPU @ 3.40GHz (3411.19 MHz)

Memory: 8169 MB

OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)

Graphics Card Vendor: NVIDIA Corporation

Graphics Card: GeForce GTX 560 Ti/PCIe/SSE2

Windows Graphics Driver Version: 8.17.0013.0142

OpenGL Version: 4.2.0

 

 

 

Link to post
Share on other sites

The more I see new features added to Second Life, both Client (Viewer) and Server side, the more it appears to me that issues people have are individual to their computers.  Now some of these issues I know are Linden induced but that would be a separate discussion from this.

Bottom line is different people get different levels of performance on their computers with different Viewers.  And some of it the solutions appear to be getting more and more complex or harder to find.

For me personally, I get the worst performance with the Official Viewer.  My JIRA on my issues.  https://jira.secondlife.com/browse/MAINT-623 .  Other people get their best performance with the Official Viewer. 

This is why I have no criticism of an individuals choice of Viewer.  As I have stated in the past, "Your World, Your Choice of Viewers."

 

Link to post
Share on other sites


Perrie Juran wrote:

 

Bottom line is different people get different levels of performance on their computers with different Viewers.  And some of it the solutions appear to be getting more and more complex or harder to find.

...

This is why I have no criticism of an individuals choice of Viewer.  As I have stated in the past, "Your World, Your Choice of Viewers."


Yes, that's very true.  It's surprising how differing results people get with similar hardware on different viewers.  Thus it's best to try many viewers to find out what works best for oneself.

 

Link to post
Share on other sites


Coby Foden wrote:


Perrie Juran wrote:

 

Bottom line is different people get different levels of performance on their computers with different Viewers.  And some of it the solutions appear to be getting more and more complex or harder to find.

...

This is why I have no criticism of an individuals choice of Viewer.  As I have stated in the past, "Your World, Your Choice of Viewers."


Yes, that's very true.  It's surprising how differing results people get with similar hardware on different viewers.  Thus it's best to try many viewers to find out what works best for oneself.

 

As you can see in my JIRA https://jira.secondlife.com/browse/MAINT-623 ,  they even went as far as to get my graphics card but were unable to repro my problem.  I've been tempted to offer to send them my computer so they can check it out on a system where it is borked.

If they wanted to send me a loaner computer to use while they had mine,I'd be glad to do it.  That is, after I remove all my porn. ;)

 

Link to post
Share on other sites
  • 1 month later...

@ Gadget Portal

Same story here. I moved to the last LL viewer today and the speed difference is really big. I was in an empty sim, firestorm lagging like a slug so I used google and found your post.

I think the problem of firestorm is arrogance and that the people making it are full of themselves, thinking they are the best. They were but they are not anymore... LL has overtaken the sleeping firestorm developers.

By looking at the history of phoenix, back to emerald, the quality is not constant.

Emerald they have used to make a DOS attack. That issue with emerald could have decided LL to ban all 3rd party viewers : This is the best example of how the people that made Emerald, phoenix and firestorm can be arrogant.

An other thing with them is that when they have a good viewer they always manage at the end of the day to make it poor.

Link to post
Share on other sites
  • 3 months later...

I have this problem with both Viewer 3 and Firestorm. Anything that's mesh enabled won't run right. Nothing rezzes and I lag so bad I can't move. I run Pheonix and it's fine. Everything rezzes and no lag (except for the regular times when SL is acting up). I can't upgrade my video card because it's a laptop that I play on. I can't afford to buy a new laptop. So what is there to do? I can't see mesh and Pheonix isn't supported anymore. When I got this computer it ran SL fast. But over the years the game has evolved and my copmuter hasn't. Everything else works fine on it and it's hard to justify buying a new computer just for SL. Would getting a new computer even help? 

Processor  2.4 GHz Intel Core 2 Duo

Memory  4 GB 1067 MHz DDR3

Graphics  NVIDIA GeForce 9400M 256 MB (It's a Mac so I shouldn't need a ton of video memory)

Link to post
Share on other sites

lol, ok all of you ready for this, I have my own little network, I also have my own personal grid on that network, seems sl has some problems, with the cache, I suggest some of you move your cache to a drive on its own, errors may show up when these moments happen, both fire storm and the sl viewer suffer from very bad lag, clearing the cache does not always work and you have to use chkdsk at boot to fix it, it seems that some of the textures don't load correctly, clearing the cache when you notice the lag can work but not every time, now I did think of one those ticket things, but do they pay me to debug, why should I do it for free, no let them work it out for themselves.

Link to post
Share on other sites
  • 1 year later...

for people that have early nVidia cards, it may be an issue of drivers.

i had the problem that lag increased the more time i spent in SL, i had to relog to get everything back at a decent speed, i tried old drivers and find out that nVidia focus more in increasing the performance of newer videocards in their universal driver sacrificing the decrease of performance on earlier cards, if the owners complain, they tell them that their videocard is old and broken, and they sell them a new one. well, i went back in time installing drivers, and find out that driver 280.26 was the one that work best with my videocard, it worked like new.

if you have an early videocard, you may consider getting a driver not very far from the date the card was released, unless is a driver very specifically made for that videocard.

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 2267 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...