Jump to content
Sign in to follow this  
Oskar Linden

Deploys for the week of 2012-08-06

Recommended Posts

I am seeing definite traffic count inaccuracies.

Can any of this be affecting the traffic counts?

Or has calculations Changed?

Tests I ran yesterday showed traffic counts to be inaccurate on both the mainland and adult continent.

Share this post


Link to post
Share on other sites

I am confused about what you are doing with BlueSteel and LeTigre

Are those web pages you reference up to date?

This bear is feeling grumpy and, rather than calling spirits from the vasty deep, has a preference for calling on the artillery. Have a nice day.

Share this post


Link to post
Share on other sites

I am very confused by this. All the testing we did on the pathfinding sims, both on the beta grid and the main grid were of no use. Our vehicles react differently now that it went grid wide then what they did during testing. Hell on the main grid pathfinding sandboxes they reacted different from one region to the other! In one sand box they would drive fine, go to the next one over and the cars sink like they were in mud. Test it on another and its fine again. And supposedly they all have the same code. I would love to hear an explanation for that. I was going to video the problem for you, but guess what, I was too busy scrambliing to fix our cars that are messed up. You know, the ones we supposedly had a fix for a month ago.

We asked and asked and begged to know when this was going grid wide and no one would tell us. Then it just gets sprung on us and in come the flood of IMs wanting to know what is happening.

Also now we have an issue with cars hanging up on phantom alpha prims. Like the prims we use for staging beams on the drag strip. You stage the cars, the lights drop and the car catches and flips down the track or takes a hard left or right and ends up on another sim. Which double sucks considering how horrid sim crossings are. Imagine crossing one at 400 mile an hour sideways and upside down. You might as well just restart sl rather than wait the 15 minutes for it to correct itself.

And the confusing thing is its not consistant. You might make 5 passes and its fine, then it just goes nuts. And these are cars and tracks that have worked fine for at least 2 years. And we have our sim and track on the beta grid with pathfinding so we could do testing. This never happened once to us there so we had no way of coming up with a fix for it or a back up plan. Now our track is down until we can figure it out. Which costs us money, which pays for our sims. We are already letting one go. If we can't get moving forward again really soon we will have no choice but to let the other one go. And we are small time. I know of another track that has 5 plus sims. If they can't race anymore I can't imagine they will shell out over a thousand a month for sims that do them no good.

Oh and we disabled pathfinding on the sim, guess what, it made no difference at all.

And the performance hits people are talking about. Some mentioned 18% like it was no big deal? if you are already running a sim with heavy traffic that can barely keep up an 18% or an extra 4MS will stop it dead. And if people can't come to your sim to shop, dance or role play guess what will happen. Yep, they will ditch them. Why pay 300 bucks for fake land (which I never understood in the first place) for something that serves you no purpose?

Here we all though you were working on making performance better and making the sim crossings smoother. This is just like the vewier 2 fiasco. You spent a year making a viewer no one wanted, and still most people use a third party veiwer that emulates the older viewers. I am simply baffled by the decisions made there.

Oh and something completely off topic, but I just have to say it. One of our employees had their account hacked. Someone hacked into it, deleted the whole inventory, left all the groups and took everyone off the the friend list. And transferred her 17K + lindens to his account. She contacts you to see if she can get a roll back of her avatar and her lindens replaced and wants to seek legal action. You put her account on hold and tell her there are no signs of compromise!! Really? She logged in in the middle of the night and deleted everything and sent all her money to an avatar she baned  a week before and filed several ARs on? And even showed you the transaction history where he transfered the money to this same avi's account. If that isn't signs of comprimise I don't know what is.

And there are huds on the market place that can crash your comptuer to desktop by overloading your video card. In some cases even damaging your hardware. I and others have filed AR's on these products and peole we know are using them. Yet the products are still on the market place and the people are still inworld. How can you knowingly and willing let someone sell a product that can damage a customers hardware? But yet the redzone device that let us detect alts of banned residents gets banned and removed from our inventories? I get more and more confused about what goes on there every day.

Share this post


Link to post
Share on other sites

Pandorah Ashdene wrote:

thank you for suggesting possible workarounds for the issue; the matter still stands that the era of one legacy prim = one landimpact is over;

Nonsense. The new accounting only applies to Items using the new accounting. Legacy prims still do, and always will, count 1 prim no matter what they are.

It's only when you bring mesh into the picture, or try to use Convex Hull to get around the prim counts, that a prim no longer = 1 prim.

Share this post


Link to post
Share on other sites

@Darien

Sad to say, Darien that SVC-8048 actually is more a littany of what is NOT working to fix cars rather than what IS.

However....I have noticed, to my considerable surprise that some vehicles which I had expected to be utterly borked, due to their interactions with SL ground, seem perfectly OK.  Probably indicates my understanding of the SL Physics engine is woefully inadequate.

One thing that I HAVE seen and that is a serious issue in its own right is that on Pathfinding sims there is an issue where terraforming is open by default.  That strikes me as being a griefers' charter.:smileysad:

Edit after restart:

erm, Oskar, LeTigre DID get Pathfinding and Havok 7 didn't it?  I have to say that there seems so little impact I don't quite believe it.

Share this post


Link to post
Share on other sites

Just reported by a customer, reproduced by me and my manager: Unlink any prim in a house, the phantom child script in sculpts stops working, sculpts go non-phantom.

Now, is there any point in making a JIRA for this?

Share this post


Link to post
Share on other sites


Darien Caldwell wrote:

To Everyone complaining about vehicles on Pathfinding:

 

Do some reading. The changes needed to make your vehicle work are there.

That's all fine and dandy except all the Vehicles I own are NO MOD.

I am all for innovation and improvement, but at what cost?  We all know Linden Lab wants to grow, but again, at what cost?  Consider this thread and what this Merchant is going to have to deal with now.  http://community.secondlife.com/t5/Second-Life-Server/Pathfinding-on-Main-server-has-destroyed-our-inworld-business/m-p/1627863#U1627863

But I guess it was all MY FAULT for purchasing NO MOD vehicles and it was all that MERCHANTS fault for selling his air craft NO MOD.

Yeah right.

Maybe there is a solution to both my problem and the above Merchant's, BUT IT SHOULD HAVE BEEN IN PLACE before this went live on the Grid.  Same as with Mesh Clothes.  The Deformer should have been in place before Mesh went live on the Grid.  Now we are stuck with Alphas all over the grid that don't always work the way people think they are working.

Sorry, but in their short sightedness it appears that the Lab is missing the bigger picture.  Unless what they are wanting to do is start Second Life all over again from scratch with a completely new user base.

Again, I am all for innovation and improvements. I am not saying that I am not.  The question is at what cost?  Is losing the good will of so many current Residents worth it?

 

Share this post


Link to post
Share on other sites

Oskar

For the Love of Little Green Apples: DID LeTigre get Pathfinding today or not?

Not for the first time I find that the server version that we (Sim 9123 Woods of Heaven RC LeTigre) see our viewers reporting has no release notes.

I am trying to determine whether or not we now have Pathfinding together with Havok 7 physics on LeTigre, or not.

Please, we need this information if we are to make rational judgements as to whether or not to disable Pathfinding on our sim.

Share this post


Link to post
Share on other sites

 

Hi Oskar,

While many of the problems with vehicles used on Pathfinder have been addressed to help with older created cars, there remains a few issues that need serious attention for newer Mesh cars. As per SVC-8048 I have discovered that if a builder uses at least 4 contact points with linden ground where all 4 are set to Convex hull the car will not sink. A single prim does not appear to have the buoyancy to ride above the edge of the land no matter what the size of the prim.

For those that run race tracks, we've found that volume detect is handled in a much different way. When a collision occurs between a physical vehicle and a prim that uses llVomumeDetect prim, size matters. For example if a prim that measures 0.5m x 1.0m x 10.0m is used it will randomly trigger a collision event (PATHBUG-156) making the car suddenly jump or veer off to one side. A fix for this for now is to make the prims as small as possible, such as using a 0.05m x 0.05m x 10.0m prim size instead of the above. Another option is to drive over instead of through the prim.

I've spent most of the last month testing and creating fixes instead of building new projects. Although I think that pathfinder is a great idea I have to ask why was it rolled out to the main with 12 major bugs still unsolved? What do we, as builder, tell our irate customers that have spent their money on products they can no longer use and blame us for the problem? My last question is that LL feels that it is only a small percentage of cars are affected, what constitutes a small percentage? I have myself sold almost 10,000 cars over the last 4 years and I'm considered small time. I really feel for those that have purchased no mod cars that are totally useless and won't be upgraded.

 

Share this post


Link to post
Share on other sites

just to let those of you know, disabling pathfinding will no effect on the glitches or performance from what I have seen. It just dsables the ability for pathfinding to work.

Share this post


Link to post
Share on other sites

Why didn't you all wait until you finished the supposed server hardware upgrades mentioned here before you deployed Pathfinding.

http://community.secondlife.com/t5/Tools-and-Technology/Project-Shining-to-Improve-Avatar-and-Object-Streaming-Speeds/ba-p/1583465


Now when you fly over Mainland diagonally across 3 sims you rubber band/lag forever.

Share this post


Link to post
Share on other sites

another problem i found, now sometimes when the sim lags, vehicles seem to lose their velocity.

 

it´s like hitting a wall, they stop on the spot, and you have to accelerate from 0.

another problem for the racing comunity.

Share this post


Link to post
Share on other sites

HELP!

OK, seriously. I am having a problem with the prim count in "About Land."  I have a 2048 plot on a Blue Steel region and about land is reporting DOUBLE the prims I have on it.

Details:

I've been setting up a new home.  It's been over a week since I last worked on it but my memory was I had about 280 prims out.  So before starting to work on it again I went to double check the number of prims I had out and and About Land reported I had 559 prims out!

I have spent over an hour scouring my plot for a culprit.  Thing is when I total up the number of prims checking the prim count on all my objects in the edit window, I still total up around 280 prims.

I have NO MESH objects out.

I really do not want to clear my land and start all over again. 

For my privacy's sake, I will not post the exact location here.

Share this post


Link to post
Share on other sites


Ayesha Askham wrote:

Oskar

For the Love of Little Green Apples: DID LeTigre get Pathfinding today or not?

Not for the first time I find that the server version that we (Sim 9123 Woods of Heaven RC LeTigre) see our viewers reporting has no release notes.

I am trying to determine whether or not we now have Pathfinding together with Havok 7 physics on LeTigre, or not.

Please, we need this information if we are to make rational judgements as to whether or not to disable Pathfinding on our sim.

Yes it did..Already set up my region. ;p

Share this post


Link to post
Share on other sites

Thanks Dari

Yes, I found out last UK night by sailing a mesh boat from Nantucket Yacht Club to Nautilus' Eastern end and back!

I am not seeing any penalties so far on our sim, so Pathfinding will stay on, but I really have no use for it as yet.

I guess Oskar's just a tad busy with the oddities that the roll threw up!  At least the Release notes are up now.

BTW, I noticed that the Release Notes bug, while it is still broken in some Main Server sims seems OK in others!  That strikes me as odd!

 

Share this post


Link to post
Share on other sites

I had my Landlord over and we spent about 30 minutes together searching the parcel for a "stray culprit" and could not find one.  Their counting came up about the same as mine did.

Decided to clear everything and start over...wasn't that far along and was tired of wasting time on it.  I could have had everything back out in less time than I had spent looking for a culprit.

I am watching object by object as I put them out if some specific item is causing the problem.

They could not make rhyme or reason of the problem either.

The SIM was still well under Prim Limits and there are only a few of us on it, all friends.

Share this post


Link to post
Share on other sites

Sim crossing has been hell since the roll-outs finished.

1: severe rubber-banding

2: unpredictable changes in heading

3: "Sticking" at a boundary, forcing deletion of vehicles, even when both regions involved are running the same sim code

     3a: The old familiar problem of the handover from A to B failing, out of range position values reported in region A while the AV is apparently in sim B, and a crash when the B-to-C boundary is encountered.

4: Whole regions invisible.

 

I've had experience of all these problems, occasional, with no apparent cause, long before Pathfinding came over the horizon. It's not impossible that they are the result of network problems. But all at once, everywhere, after the Pathfinding roll-out completes, that's a disturbing coincidence.

There were reports that Charlene Linden was escalating one set of reports as a bug, but I never say any clear report of whether it was linked to a particular RC.

Is there a list anywhere of symptoms of particular Vehicle problems? And please, not a JIRA entry. The JIRA makes my poor head hurt. I really doubt that the problems I see have a unique cause anyway, except in the general sense of Linden Playtime.

And does Linden Labs have anyone responsible for communications yet? I don't recall hearing anything since the last communications tsar quit.

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...