Jump to content

BAD GRAPHICS!!!!!


You are about to reply to a thread that has been inactive for 3011 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

until today, my secondlife graphics have always been pretty sweet. however today evrything looks like crap. jaggies everywhere and every flaw screaming loudly.

I have changed nothing so IDK why this should suddenly happen.I tried changing all kinds of settings but nothing helped.

Its not my computer...its always been great and I went inworldz with imprudence just before that and everything was lovely.

whatever is different in the latest browser, put it BACK. and how do I get the previous version of the SL viewer?

Link to post
Share on other sites

New deployments were done today that may have somehow effected your graphics.  Its happened to me,  A few months ago, I was logged out because i didn't see the restart message and logged back in a few minutes later when it came back up. i was only able to see one terrain texture.    Since my system is pretty new and all graphics other than in world wer ok, I didn't think it was me.  However i found that a driver fixed the issue.  Oddly the deploy didn't have anything to do with graphics.  Just figured that the upgrad fixed or introduced one thing, and broke another. at least for me.

Link to post
Share on other sites

I use the preferences settings all the time, so I am used to this stuff and you can get all into changing stuff.

But, here is a fast method. Ctrl+p, then graphics tab and then the slider up to higher than what it is at.

If you still have jaggies then you need to turn on Anti-Aliasing, Aliasing is what causes jaggies.

Ctrl+P and then to the graphics tab.

You will need to set it to advanced and then hit the hardware button at the bottom right hand side of this window.

AA or anti aliasing, 2X may work fine but some like it way up as high as can go I bet. More x the smoother and softer the edges look.

Then, if you still have jaggies and nothing happened (you might need to restart the viewer) you need to go to your graphics cards software and somehow choose a setting that allows the applications you run to handle ani-aliasing.

But, if it is already set to applications choice, then try making it overide it and do at least 2x.

Catalyst is the name for ATI, and I think nVidias is in teh Control Panel. If you are on mac, this is something I don't know about and there are different deals between ATI and Apple...so not sure if catalyst crawled it's way into macs or not.

If you like imprudences settings then maybe you can copy them down and basically set the other viewer the same because they may share the same exact settings! All found by clicking the advanced checkbox or button in the Preference menu.


Link to post
Share on other sites

Out of curiosity, how loudly are these flaws screaming? (upload a photo so we can see please).

In your shoes I would check I'd got the latest graphics drivers installed, and adjust my screen resolution. I rarely fanny about with the settings inworld, because it tends to get a bit like asking a cat to unwind a ball of wool.

Link to post
Share on other sites

There is this one thing that makes things look uglier...mipmap based settings in my graphics driver. I am not aware of anything SL viewer could to do change this, as far as I know it is mostly a graphics software based thing. You can find it in your graphic hardware providers software. I know Catalyst is the basic name of ATI's software and in there you see a setting called mipmap or something like that. Mip stuff is set on or higher to help, but for me it makes textures ugly in SL! So, I turn it off and things are a bit softer and not so...well, grainy ugly. I like grainy, but this grain I see is ugly grain.

Maybe the newer LL viewer somehow has something running to affect mipmaps? hhhm, I don't know and don't keep up on all this stuff. Mip settings are supposed to make stuff better looking at some angles or distances....sadly, they don't work well for me in SL with ATI card. I don't know about nvidia, even though I have run an old card of theirs because I never tried to fix much there. I should really, I think I lost anti-aliasing but the past so many months just didn't care because I just wanted to walk and test sim crossings a bit, as well as temp rez as a way to thwart lost items annoying people when the operator crashes out. Uh, sorry I can't be of more help.

Link to post
Share on other sites

Go into "Preferences - Graphics - Advanced - Hardware" and see if "Enable Texture Compression" is selected. If it is, de-select it and restart the viewer. It's a new setting that lets things run better on lower-end computers but can cause blotchy graphics in some situations, especially with ATI/AMD cards.

Link to post
Share on other sites


Tenly wrote:

its not just clothing textures. the skin is all bad looking now. Im not having this problem with any grid except SL.

Screen Shot 2012-08-01 at 9.38.11 PM.png

Thanks for providing the photo. I never looked at my own armpit up that close before.

Comparing the above with my avatar's armpit, I clearly see the difference. Marigold

 

Theresa's advice looks worth a try. Please let us know what fixes this problem for you.

Link to post
Share on other sites


Charolotte Caxton wrote:

Mip maps?

Yeah, it is some kind of graphics thingy. I really should know more about it, but I can't remember! In fact, the compression setting sounds like that stuff a bit, but this setting (maybe it is not mipmaps and some other similar name....hhhm) I was referring to is more to do with sharpening things at distance or angle....I think I may have got it mixed up with aniostropic mip mapping....confusing stuff, but I am still learning this game graphics stuff and settings are sort of self explanitory and I don't read the titles and names so much and leave it when it all works, as far as catalyst goes. Now and then I will crank it up or down for pics, but that is rare these days and I don't look so close at names and...well, yeah, I am mixed up on these two maybe. Aniostropic filtering is also maybe it....wait, maybe aniostropic filtering IS anioistropic mipmapping? Confusing stuff.

Link to post
Share on other sites

Hey Theresa Tennyson, 

I still dunno what started the problem because I never changed anything originally. I did turn on the compression last night and things looked okay. then I go into this morning and things are jaggy again.


however going into prefs again, I realized when you check this setting ON it turns off antialiasing and bingo jaggies. so turned it off, turned anti-aliasing back on and restarted and looks good. for the moment.

and for everyone who kept asking me what I changed...Im pretty sure I said I changed NOTHING between the time things were good and the next day when things were crappy.

Link to post
Share on other sites


Tenly wrote:

Hey Theresa Tennyson, 

I still dunno what started the problem because I never changed anything originally. I did turn on the compression last night and things looked okay. then I go into this morning and things are jaggy again.

 

however going into prefs again, I realized when you check this setting ON it turns off antialiasing and bingo jaggies. so turned it off, turned anti-aliasing back on and restarted and looks good. for the moment.

 

and for everyone who kept asking me what I changed...Im pretty sure I said I changed NOTHING between the time things were good and the next day when things were crappy.

Nothing nothing, or nothing graphics wise, or nothing settings wise, or absolutely nothing at all? Some people say nothing and mean nothing but this one thing that they didn't bother to mention since they were sure it couldn't have affected anything, that's why I ask :)

Link to post
Share on other sites

Mip mapping? I use Ati, I have messed with the ati settings and I can't notice a difference in graphics quality in SL when I do, I cranked them all up, and the ones in SL also, have I reached its maximum potential? Mip mapping... I am still intrigued.

Link to post
Share on other sites
  • 5 weeks later...

ugh, didnt work. I get this fixed and the next time I log in the graphics are all crappy again. so loved the SL viewer until 1-2 updates ago. looking more and more like firestorm is going to be my viewer of choice because EVERYTHING looks great there!

Link to post
Share on other sites

the only thing that seems to work is rebaking..however that lasts only for a few minutes, sometimes longer and then the textures on skin etc are all blotchy again. I wish I could get a version of the SL view a few versions back. and as for firestorm..when I wrote my original complaint all was good there, but with the update I just got today, its now just as bad as SL for making skin look like my avatars have infections.

Link to post
Share on other sites

I know it has been said in the very first response, but I suspect it has got something to do with your cache, or possibly with your graphic card (settings). I have to get a bit technical, even though that isn't my field of expertise, if I'm on to something maybe someone else can elaborate..

You say rebaking solves the problem. What happens when you rebake, is all textures on your avatar are merged together by your viewer into one texture and that texture is uploaded to the SL server. The server sends that texture to other viewers so others can see you textured.

Then there's the cache. It stores all your textures. When it's full, one new texture downloaded from the SL server means one is kicked out. Your graphics card memory works more or less the same way.

THEN there is mipmapping. Mipmapping is making low quality versions of all the textures that are used by the viewer. When an object is 100 meters away, it doesn't need that 1024x1024 texture, so SL will download a smaller version of that texture, or your viewer sends a smaller version to your graphics card, I'm not sure.

So what I think is happenening is either the high quality version of your baked avatar is kicked from your cache because it's too small, or your graphics card doesn't use all its memory giving the same effects. While writing this, I remembered my SL business partner had some issues with blurry textures. Turned out the viewer decided to lower the memory in preferences to 80MB instead of 512 MB for no apparant reason.

What you can do is go into preferences (ctrl-p), open the graphics tab and click hardware options. You should see the amount of memory your graphics card will use (with a maximum of 512) Make sure the slider matches the amount of memory your graphics card has. If it's a cache issue, you might want to clear your cache manually from your computer, make sure your HD isn't fragmented and see if your cache size isn't too small, I think that's under "advanced" or maybe "network" in preferences. It defaults to 512 MB which should be fine under most circumstances.

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 3011 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...