Jump to content
Sign in to follow this  
LunaMetamorphia

Camera Error When Wearing Rigged Mesh Avatar?

Recommended Posts

I just created my first rigged mesh avatar.  Or so I thought.  When I wear it, it forces my view up to the sky.  When I take it off, my view stays up in the sky.  I have to relog to get my view back to normal.  Any ideas on what is causing this?   I created it in Maya 2011 (I used Reed Steamroller's skeleton and the Collada exporter).  Thanks in advance!

Share this post


Link to post
Share on other sites

Nevermind.  I tried again only this tiem I didn't check "Include joint positions" and it works fine now.  Figured I'd leave this posted, incase anyone else has the same problem.  ;)

Share this post


Link to post
Share on other sites

What an odd glitch... ive uploaded many rigs without checking off include joint positions.

What program did you use to rig it?

 

I know it's fixed but im just curious.

Share this post


Link to post
Share on other sites

I had the same problem in 3ds max a few times, i think its caused when you want joint positions but you haven't weighted all 26 bones, and it seems to put the unweighted bones in random positions, and the mSkull bone seems to make your camera go crazy.

To fix with included joint positions just make sure you select all the bones with the mesh before you export, so that the positions for the unweighted bones are stored in the dae file

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×