Jump to content
Sign in to follow this  
Milla Michinaga

Maya weight painting

Recommended Posts

Does anybody know why I can't see the colours when I weight paint in Maya? In all the tutorials I've seen they just start painting on the mesh and it's very easy to see with the colours what they're painting. I don't get that. Am I missing something obvious here?

I'm working in Maya 2013.

Thanks.

Share this post


Link to post
Share on other sites

Mi Milla,

What exactly do you mean by "colors" in this context?  The weight painting is actually alpha mapping, so there are no RGB colors, just grayscale. 

Consistent with standard alpha mapping logic, white means 100%, black means zero, and all shades of gray fall in between.   So, if an area of the mesh is painted white, that area will follow the selected joint 100%.  Any area that is painted black will not follow the selected joint at all.  Areas that are painted gray will follow the selected joint a little bit.  The lighter the gray, the stronger the selected joint's influence.

If you meant that you don't even see the grayscale colors, then you're doing something wrong.  Here are all the things you need to do, to be able to paint weights.  Make sure you didn't miss any.  Some of these might be super obvious, but I'm betting at least one or two of them probably are not:

1. Make sure your viewport is set to smooth shading or flat shading.  If it's wireframe, you won't be able to see the surface.

2.  Bind the skin to the skeleton, with a smooth bind.  This is important for two reasons.  First, if it's not bound, there are no weights, and you cannot paint what doesn't exist.  Second, it has to be a smooth bind, rather than a rigid bind, because rigid binds work on a different principle.  If you already bound it with a rigid bind, detach it, delete history, and re-bind it.

3.  Select the mesh (in object mode, by the way, not component mode).  Don't select the skeleton at this poin.  The skin is what you'll be painting on, so the skin is what must be selected.

4.  Grab the Paint Skin Weights Tool.  You should see the colors change immediately to the alpha map colors.

5.  Go into the Paint Skin Weights Tool's settings, near the top, you'll see the influence list, which shows all the jonts in the skeleton.  Select a joint, and the colors on the skin will change to show that particular joint's influences on the skin.  Paint as desired, and repeat for each additional joint. 

(Tip:  It's a good idea to rotate various joints as you work, so you can see how the skin behaves when put into in different poses.  Just don't forget to go back to the bind pose when you're done.)

6.  When you're done, let go of the Paind Skin Weights Tool (by grabbing any other tool), and the model display will return to its normal colors.

7.  Delete non-deformer history, from the mesh.  Do not delete the entire history, or you'll destroy the skeleton.  Only delete the non-deformer history.

 

If you did all that, and it's still not working, please explain your exact process, in the same level of detail that I did, so I can try to see where specifically you're going wrong.

  • Like 1

Share this post


Link to post
Share on other sites


Chosen Few wrote:

Mi Milla,

What exactly do you mean by "colors" in this context?  The weight painting is actually alpha mapping, so there are no RGB colors, just grayscale.

 

Can't you change that in preferences? In 3ds max the colors vary from gray through blue to bright red, not from white to black. I can imagine that is a lot easier to work with than shades of grey.

Share this post


Link to post
Share on other sites


Kwakkelde Kwak wrote:

 

Can't you change that in preferences? In 3ds max the colors vary from gray through blue to bright red, not from white to black. I can imagine that is a lot easier to work with than shades of grey.

I've never seen or heard of any way to change it.  I'm not sure why anyone would want to, anyway.  Alpha logic is so simple and straight forward.  If I want to increase a joint's influence on an area of skin, I simply lighten the shade; if I want to decrase it, I just darken the shade.  Easy peasy. 

I don't see how adding a rainbow of colors to the mix would make the process any simpler.  If anything, it seems it would add a level of complexity that just doesn't need to be there. 

That said, I'm guessing we're both probably just biased by what we're used to.  Most likely, neither method is superior or inferior; they're just different.

In any case, your comment did remind me of something I forgot to mention earlier:  skeleton colorization. 

Milla, if you've colorized the skeleton, the Paint Skin Weights Tool can be set to make the the bone colors appear on the skin.  This is so you can quickly see which bones are influencing which parts of the skin, without having to go through and select each joint, one by one.  To turn this feature on, go into the Paint Skin Weights Tool settings, open up the Dislplay section at the bottom, and check the box for mult-color feedback.  You'll find it's handy to flip it on and off as you work.

Share this post


Link to post
Share on other sites

In Maya 2012, you can use colors (such as the rainbow gradient you see in many tutorials) by doing the following-

While paint skin weights tool is active, go to your tool settings and scroll down to gradient.  Expand it, then select the box next to where it says use color ramp.  From here, you can use the default color ramp, which is rainbow, select one of the other default color ramps, or even define your own.

I'm not sure if this works in earlier versions of Maya.

Hope this helps!

  • Like 1

Share this post


Link to post
Share on other sites

Ah, good to know.  Thanks for that, Sae. 

That feature definitely does not exist in Maya 2009, which is what I use.  I really should upgrade, one of these days. :)

Share this post


Link to post
Share on other sites

No problem.  And yeah, I was almost certain it didn't work in previous versions of Maya, but I never tried weighting until I had already upgraded.  :)

Share this post


Link to post
Share on other sites

So I'm still not able to see the colours. I have narrowed the problem down a little by doing some testing.  I'v come to the conclusion that its my specific scene where the problem persists. I'm using a scene that I downloaded from the Standard Sizing project that comes with standard sized avatars and skeletons (extremely useful).  

If I open a new scene and throw together a basic skeleton that I skin to a cylinder I get all kinds of lovely colours when I go to the Paint Weight Tool. If I do the same in my work-scene (where my mesh lives) I get no colour.

Could there be a setting that is specific to a scene that could cause this problem?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...