Jump to content

Mesh Texturing Help


Mariano Ree
 Share

You are about to reply to a thread that has been inactive for 3433 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Having problems with the mesh texture for my Tank top.

So at the seam where the meshes join I seem to have some weird Bright white spots or sometimes Dark spots. It doesn't matter what I do to the texture its always there no matter what. I can only get rid of when I click "Full Bright" on the mesh Tank in world. So Im guessing its a Lighting issue.

I like how the Mesh texture with out "Full Bright" on looks. The only thing that's killing it is the Spots on the seams.

So How can I get around to fixing this or how can I make the Full Bright Texture look like the one with out it minus the white/Dark spots on the side.

Mesh problem.jpg

Link to comment
Share on other sites

What I would really like to see is the mesh...

Depending on how you made the mesh you may have a seam with a row of double vertices, or a crease.

You may also not have the adjoining polys sharing the same vertces. Try selecting a single poly along the edges of the problem polygon. Move it and see if the faces are really joined. 

Link to comment
Share on other sites

Yea I was going to ask if you actually tried to recalculate the normals after you modeled it. This will make sure all your normals are going the right directions.

in edit mode . highlight the model and recalculate should be in the mesh tool panel

Also when you are painting your UV there is an option in the paint panel thats says Bleed. rais that value up to 2 or 3 to ensure the texture paint bleeds past the UV boundaries/ seams

 

I have also seen this kind of happen when premultiply is enabled in the materials texture panel

Link to comment
Share on other sites

Ok so heres the mesh in Wire. The one on the left is how it looks normaly. The one on the left is what happened to it when I tried the "recalculate the normals" option.

Note: I'm using MD2 to make the Mesh and it looks fine in there.

mesh problems 2.jpg

 

Link to comment
Share on other sites

That looks like duplicates. If you havent tried already, then

 

  • go to edit mode
  • select all vertices
  • press "w" -> remove doubles

The only other idea i have is that the UV map is broken. Maybe overlapping UV faces ?

Maybe you use a subdivision modifier (i don't think so, but just in case) ? that can create issues when your mesh contains triangles...

 

Link to comment
Share on other sites

Attach a Decimate modifier to the mesh and see if you get an error message telling you that the mesh is non-manifold.

Non-manifold meshes don't have a clear separation between inside and outside, for example if an edge is connecting more than two faces. Recalculating normals on such a mesh will fail and leave shading errors behind like the ones in your second screenshot.

Sometimes meshes become non-manifold by accident if you remove double vertices. I see a lot of overlapping faces in that mesh, so this is likely what happened.

If the mesh imports as several parts that you have to connect manually, don't use the Remove Doubles function on the entire mesh. There is a better way to do it which will avoid the non-manifold trap. I'll describe that in another post if you are interested.

Link to comment
Share on other sites

OK, here's what usually works for me:

The basic challenge is to separate the edges that you want to merge from those that you want to keep separate. Remove Doubles will ignore unselected vertices, but how do you select the right vertices if the mesh is a mess like the one above, with lots of overlapping?

One method to do it is by temporarily attaching a Smooth modifier and applying it to the editing cage during Edit mode. Smoothing will shrink the unconnected parts of a mesh so that doubled edge loops get pulled apart and become visible gaps. Now it is very easy to select the opposite sides of such a gap using Alt-Shift + Right-Click and then applying the Remove Doubles function only to those vertices. The Merge Distance should be set as small as possible first and then gradually increased if necessary until the gap closes completely and the number of selected vertices (displayed at the top of the screen) is exactly half the previous value. After all the gaps have been merged this way, the normals can be recalculated and the Smooth modifier be removed.

Unfortunately I can't upload screenshots from my current location. Maybe I'll add them later.

  • Like 2
Link to comment
Share on other sites

That's exactly what I thought was going wrong. That the inside of the mesh was geting mixed with the outside of the mesh. Is it possible you could make a step by step expilation of what your doing in the post. I am prety new to Blender and you prety much lost me at the adding a modifier.

Also does anyone know why the texture looks fine when I apply "Full Bright" in SL. Or when I apply the View Port Shading in blender to Texture. I'm guessing its how the Lighting bounces off the mesh?

 

Mesh problems 3.jpg

Link to comment
Share on other sites

Full bright effectively turns off the shading normally applied in the viewer to mimic natural lighting. This means that the normals, that indicate the direction perpendicular to the light-reflecting surface, no longer affect the brightness of the light coming from the surface. This supresses problems that otherwise arise from inappropriate normals.

Link to comment
Share on other sites


Drongle McMahon wrote:

Full bright effectively turns off the shading normally applied in the viewer to mimic natural lighting.

@ Mariano Ree:

Avoid using full bright in clothing items.  Full bright clothes will look very odd at night.

(The same applies to almost anything else except light sources.)

Link to comment
Share on other sites

Is this the mesh exactly as MD2 exported it?

It seems that the inside and the outside are welded together in a single seam on the left and right side. So it's not Remove Doubles that caused it.

I guess the best way to fix that is to delete most or all of the inside faces. They won't be visible anyway when the mesh is worn, except near the shoulders maybe.

Press TAB to enter Edit mode. Press A once or twice to make sure that no part of the mesh is selected. Switch to Face Select mode and enable "Limit selection to visible". Press C to activate the circle selection tool. Now you can select faces simply by holding the left mouse button and sliding the circle across the mesh surface. Holding the middle mouse button will unselect faces. Pressing the right button will deactivate circle selection. Select all the outside faces and some of the inside faces near the shoulder that may be visible when the mesh is worn. When done, press Ctrl-I to invert the selection and then X to delete the selected faces.

Recalculate the normals and see if there are still shading errors. Press TAB again to leave Edit mode. Attach a Decimate modifier and see if it still complains about the mesh being non-manifold. If the shading looks good and the modifier does not complain, you're done. Don't forget to delete the modifier.

Link to comment
Share on other sites

Thanks Masami the worked the lighting gets fixed once I delete the insides.

That is how MD2 Exported the Mesh that I made. I think the problems is that I made 2 different sides the outer mesh and the inner mesh. So that when I exported it wouldn't look like a one sided flat mesh with texture only on the outer mesh.

Now if I just do it normally and just make a outer mesh and export it looks like the picture below. The plus side is I don't get problems with the seams and lighting.

 

Mesh problem 5.jpg

 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3433 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...