Jump to content
Sign in to follow this  
Emil Praga

GPU usage only 50%

Recommended Posts

Why does SL use only 50% of my GPU performance? i meen..... from 730 Core Clock it uses 405 constantly, from 1455 shader clock it uses only 805 and from memory clock 1800 it uses only 324, so wtf?

Share this post


Link to post
Share on other sites

I can change the viewer to drop AA and several other features and push tasks off to the GPU. If I let the viewer do the work, I run at about 6 to 25 FPS with the avarage in 8 to 13 FPS on HIGH with L&S, Ambiant, and Sun/Moon. If I do, I see the GPU running at 99%.

I can leave all the graphics render process in the viewer and still get 6 to 25 w/6 to 13 avarage and the GPU bouncing between 20 and 60%.

The overall render image and user interface is much better if I let the viewer handle the graphics. I'm puzzled because others with similar setups are running 30 - to 50 FPS. The only significant difference appears to be they are in Win7 - 64 bit.

I've tried over clocking to push the CPU to 3Mhz. That gets me from 15 FPS to a weak 17 FPS and runs the box way hot.

Second Life 3.3.3 (258100) May 26 2012 05:42:20 (Second Life Development)
Release Notes

CPU: Intel® Core2 Quad CPU Q6700 @ 2.66GHz (2666.66 MHz)
Memory: 3326 MB
OS Version: Microsoft Windows Vista 32-bit Service Pack 2 (Build 6002)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 560 Ti/PCIe/SSE2

Windows Graphics Driver Version: 8.17.0013.0142
OpenGL Version: 4.2.0

libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
J2C Decoder Version: KDU v6.4.1
Audio Driver Version: FMOD version 3.750000
Qt Webkit Version: 4.7.1 (version number hard-coded)
Voice Server Version: Not Connected
Built with MSVC version 1600

When I asked what others were getting (How Fast is Your Viewer? - Second Life) the most noticable difference is in the 64 bit systems.

Share this post


Link to post
Share on other sites

its actually not even 50%, its 40%, but its probably because its using only 400 MB from its 1 GB memory, the Clocks go as high as they are set, anyway, i get great FPS no matter where or what... i was thinking if it would use its full capacity, it could get even more FPS, no?

Share this post


Link to post
Share on other sites

ok i have GTX460 1GbRAm, i play on ULTRA SL but with some customising of myself like Avatar Impostors reduced to 5,ummm on empty SIM i get 130 FPS aprox, and in very crowded places like clubs with around 30 avatars in screen i get 40FPS

EDIT: with shadows enabled in crowded places i get 20-25 fps, on empty sim i can remember, over 50 anyway

Share this post


Link to post
Share on other sites

Let me sign off on this note...

What you are seeing from all of these metrics (statistics) are averages.  You've noticed a tradeoff between the quality of the rendering and the number of FPS(frames per second).  More quality, less FPS.  If you were able to look at all of the REAL TIME metrics for the graphics card, and not the AVERAGES, it would appear to be working a lot harder than the AVERAGES would indicate.  

Seems like you are running Windows XP 32 bit, which is over a 10 year old operating system.  There must be bottlenecks there.  Finding them and making the adjustments in the operating system is a huge task.  To find them, try typing in MMC(Microsoft Management Console) at the RUN command box.  Tune the hard drive(s), tune the CPU(s), tune RAM.  

"The only significant difference appears to be they are in Win7 - 64 bit."

The Serenity Prayer

God grant me the serenity 
to accept the things I cannot change; 
courage to change the things I can;
and wisdom to know the difference.

Share this post


Link to post
Share on other sites

CPU: Intel® Core2 Quad CPU Q8300 @ 2.50GHz (OC 3000.17 MHz)
Memory: 5120 MB (1066mhz)
OS Version: Microsoft Windows 7 64-bit (Build 7600)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 460/PCIe/SSE2

Windows Graphics Driver Version: 8.17.0013.0142
OpenGL Version: 4.2.0

Internet Connection >>> http://www.speedtest.net/result/1982977422.png

Share this post


Link to post
Share on other sites

yeah i guess you are right:mansad: , actually i overclocked it like 3 days ago to 3ghz cause i needed better performance in another game, now it runs epic

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...