Jump to content

Rigging and uploading - problems


You are about to reply to a thread that has been inactive for 2962 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I'm telling you, for every hour I'm working in blender (2.6) I spend 2 hours looking for answers to bizarre problems on google...


Anyways, Hello everyone. I'l still learing and I've come across some problems I can't find an answer to.

I'm doing puffy sleeves in mesh, right and left sleeve, so after finnishing rigging and testing it within blender, I save each sleeve in .collada and go to the SL test grid to upload.

No problems here, but the mesh wasn't moving with the avatar. Which was the mainr eason I wanted to learn mesh; I like the way the clothes move with the avatar. A little research latter and I realise I had to actually"apply" the modifier called armature (I didn't even know it was a modifier!). So I did that for both sleeves and saved a new collada file for each.

They are exactly the same mesh, but with different dirrection.

Now I go to upload and three things have happened.

1. The file refused to load, for no reason. It tells me to check the log, but I don't know what that means and I get no info on what the error was. After deleting the collada files and making new ones (and I had to this several times with exactly the same file), it stopped giving this error. No idea why, or how, or... *shugs*

2. the file loads and I can check the box to enable skin weight (note: if I try to check the box about bone joints, it gives me the loading error again), but after I load it and wear the object, it doesn't show up. If I rezz the object in front of me in a sanbox, there it is, but it doesn't show at all when I wear it.

3. Now, one sleeve has the problem I described in 2. but the other sleeve, which is exactly the same, modifier and all, doesn't let me check the box about skin weight.


PLease, someone help me figure all these problems and explain to be, WHY are they happening. I want to understand them. I have now exhasted both my resources and myself looking for answers, tutorials, forum answers and everything else. I'm more than willing to share the blender file for you to look at (tthough, you have to tell me how to do that).


Thank you so very much for any help you can give me.

Link to comment
Share on other sites

  1. I do not see any reason why you would want to apply the armature modifier here.
  2. So you rigged your mesh, you weighted it and it works in Blender as you expect ? It moves along with the bones and behaves well ? I assume thats the case.
  3. Now did you take care that your mesh contains 21 vertex groups all named according to the SL Avatar bones ? That is a constraint introduced by Linden Labs. No idea why.
  4. When that is also done, then you will want to export only the selected objects to .dae and you will want to enable "export for Second Life" in the Collada Exporter (assuming you have at least blender 2.62)
  5. then you will import your mesh to Second life. Take care that you have to enable "with weights" on the OPTION Panel of the SL Importer. Just telling the previewer to display the weights is not enough!

If all went well until here, your mesh should be fine as soon as you wear it. But ... a few things still can go wrong and all can lead to more or less dramatic reactions:


  • duplicate vertices make trouble
  • very small faces make trouble
  • vertices weighted to more than 4 bones ... sometimes make trouble
  • not all bone weight groups defined, make big trouble
  • not all vertices weighted will be rejected by the importer
  • additional bones besides the SL avatar bones: no good!
  • shape keys in your mesh ? could make funny results.
  • forgot to unwrap ? no trouble, but textureing won't work.
  • try to export textures along with your rigged mesh ? broken feature, i believe the SL Importer has a bug here.

well, its a lot that can go wrong...

Link to comment
Share on other sites

Gaia, you are a lifesaver!

It works perfectly now. I still haven't tested textures yet, just wanted to get the model perfect before I texture it, and now the model's working perfectly.

I actually think the problem was that I never even knew there was an "export to SL" option when I saved collada. It's very missable, tucked away in the lower left corner. Only when I went to specifically look for it did I find it.

After that, I just the upload like I normally do and it worked like a charm.


Thank you so much! Your explanation was spot on. ;)

Link to comment
Share on other sites

I'm having a similar problems! But I'm at a complete lost all the guides I looked up are out of date and all over the place its just fustrating.

I'm using Blender 2.62. I rigged the mesh its wieghted and moves correctly with when i move the bones in Blender. I export the Collada file with "export for Second Life" checked.

The problem I'm having is when I try to upload in SL it does not Allow me to pick the skin wieghts. Its Greyed out. Did I miss a Step?

I looked at the Vertex groups in my mesh shirt im trying to upload and it only shows 9 named all according to the chest area bones. There is also one more thats just named Object. Is this whats causing me not to check on the load wieghts in the SL uploader?

If so now the question is where did I go wrong? How do I make sure all 21 full Vertex groups get in my mesh shirt?

Link to comment
Share on other sites

I just rewrote a tutorial on setting up the base file for rigged mesh: Second Life Mesh Clothes Blender 2.6 Setup 2012 Tutorial. It is a text tutorial.

So, it is about as up todate as possible. Also, tutorials are only out of date in the sense that the user interface of Blender has changed. The concepts used in modeling and rigging mesh have not changed. It is a bear changing from 2.49's UI to 2.5x and 2.6x UI. But, things are way easier to find in the 2.5+ versions.

If you rigged the mesh using the tutorial for general rigging rather than Second Life rigging, that is the problem. You need to use the Second Life armature for rigged mesh going into Second Life.

Link to comment
Share on other sites

It's wonderful when peopl actually update their tutorials. Thank you Natales: I actually followed your tutorial a lot.

My corset works perfectly and is looking good, but still having problems uploading the puffy sleeves. It has that problem where, I can upload it just fine and check the weight, but when I "wear" it, it doesn't show up. Not even with an alpha in place.

Could you explain why this happens? I've had this happen before with the corset but I have no idea what I did to fix it. Just that one day it was fixed. xD


Also Natales, could I make a suggestion? I think it would help if you added a FAQ section to the tutorial, to provide solutions to common problems. Just my 2 cents. ;)

Link to comment
Share on other sites

If you are using the Avastar plugin, you need to use its export button instead of the Collada export under the File menu, and it will make sure to add the missing groups.


If you aren't using Avastar, check your list of vertex groups against this one:

- crucial list (21)--


To add the ones you are missing, you do it one by one. Under Vertex Groups, click the plus icon then type in the missing vertex group. Repeat those steps for each missing group. 

In the future, if you parent your model "with empty groups" to the armature first before adding weights, you will get all the needed vertex groups placed in the item from the beginning.

Link to comment
Share on other sites

I'm happy you got it working, Mariano. It's always a triunf when someone new to mesh gets stuff working properly xD

As for me, I still can't get my puffy sleeve to show up. Someone told me the mesh might be inverted and to try and recalculate the normals, which I did... but still no luck.

Link to comment
Share on other sites

Update: I found an excellent in-game help group and they managed to figure out hat was wrong: it seemes I didn't weight the mesh after all. I must have gotten confused.

It was a simple problem with a simple answer after all. It always is...


To add to that, me and the person who helped solve this problem foudn out something: I was using the "bone weight" addon from machinimatrix and supposedly that addon doesnt work on blender 2.63, only on 2.62.

I'm using the 2.63 version and the addon works fine. It might be that I'm just lucky, but I would suggest people with blender 2.63 still give it a try and test it out if it works for them. You might get lucky like I did!

Link to comment
Share on other sites


Yes, it looks like the tool still works on Blender 2.63. Although i could have sworn it would break because the mesh implementation has changed a lot. But well, facts are facts. And there is hope again to get that tool into the official distribution of blender one day :)

Link to comment
Share on other sites

  • 1 year later...
You are about to reply to a thread that has been inactive for 2962 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...