Jump to content

Tips and Tricks

  • entries
    43
  • comments
    559
  • views
    44,668

Contributors to this blog

[GUIDE] Configuring your firewall to allow access to Second Life

Sign in to follow this  
Torley Linden

46,713 views

Whether you're in a corporate environment or have a few computers connected at home, your network likely includes firewalls, which prevent security intrusions and other kinds of unauthorized access. If you're trying to connect to Second Life behind firewalls that are too restrictive, you may be blocked unless you open ports and otherwise allow the necesary traffic through. If this has happened to you and you don't know which ports to configure, check out:

Configuring your firewall to allow access to Second Life

Obligatory disclaimer: don't "play" SL at work unless it's on company business (like me, hah!).

Thanks to Kyle Linden who recently provided me with updated details. Speaking of, I should also emphasize: over time, firewall details change, so if you've used the guide to connect successfully, you'll surely want to bookmark it if something breaks in the future.

Please let us know your feedback in the comments!

Sign in to follow this  


0 Comments


Recommended Comments

The settings are very important to run SL in a wireless LAN. One thing not to do, add 80 and 443. On my router any opening of ports makes them exclusive to one computer.

I would like to see what to set inbound and outbound. In such a way anyone with a router can figure out what to open.

Without opening of ports on my router SL becomes very laggy.

Share this comment


Link to comment

Inspired I checked traffic

I have traffic on the following incoming ports

Voice

  • 52061
  • 52062
  • 10501
  • 10502

SL Plugin

  • 50659
  • 51620

Secondlife

  • 12043
  • 44125
  • 50662
  • 51621

That excludes http, https and login handshake.

I have set the above ports in my NAT as Virtual Server linking them with my local IP.

The Wiki is incorrect. Or I'm infected with a bug. Can you check that Torley?

Share this comment


Link to comment

hm. after a relog the ports have changed.

slvoice

  • 10501
  • 50502
  • 52238
  • 52248
  • 52249

slplugin

  • 52230
  • 52229

secondlife

  • 52232
  • 52231
  • 44125
  • 12043

The only ports that appear persistant are 12043 and 44125

Share this comment


Link to comment

This is quite normal. The ports in the wiki posting are outgoing ports. The incomming ports are negotiated while establishing the connections and will move every time you establish a new connection.to the SL and voice servers. This is how IP works.

 

Your firewall should support a method to open the incomming port automatically based on this negotiation. With my linux based firewall this is done with

iptables -A FORWARD -i $DSL -o $LAN   -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -o $DSL -i $LAN   -m state --state ESTABLISHED,RELATED -j ACCEPT

The "--state ESTABLISHED,RELATED" says: If there is an outgoing connection established, open the related incomming port, which is negotiated while establishing the connection.

I don't know how your Firewall is configured, but there should be such an option. Most Connections to the internet need it.

Share this comment


Link to comment

The identified ports are the LL outgoing, me incoming ports. The me outgoing ports are somewhere in the 50xxx-51xxx range. My software filrewall just declares slvoice, slplugin and secondlife as trusted so they can chat whatever they want.

On my (wireless) router I know ports have to be opened to prevent massive lag. My NAT has two methods for that, next to DMZ that I don't want to use. Virtual Server linking incoming port (range) with a local IP. Special Applications linking outgoing Trigger ports with incoming ports (range).

I have used the Special Applications so far without really knowing what I was doing, but it worked making SL lightning fast. I will now try Virtual Server on 5060, 5062, 12043 and 44125. The rest can be negotiated as usual.

I found it odd not seeing traffic on 5060 or 5062, perhaps that only happends doring negotiation during log-on setting another port. Also I find it odd to see 44125 as a very stable port for traffic.

I could sniff out traffic and make stats, but that feels like energy wasted. I just want to make sure NAT isn't a cause for lag.

Share this comment


Link to comment
×