Reply
leyna
Posts: 135
Registered: ‎05-22-2011

Chrome and SLurls

I've had this issue ever since I began using Google Chrome a couple of months ago. (it's set as my default browser) 

Anytime I try to TP from a SLurl in Chrome, I get an "External Protocol Request" pop up that says GC needs to launch an external application to handle second life links and it wants to launch my viewer even though my viewer is already launched. 

Has anyone else had this problem?  

 

Jarnz Dench
Posts: 110
Topics: 1
Registered: ‎04-01-2009

Re: Chrome and SLurls

Reply to leyna - view message

I've had this since I first started using Chrome, I just click Launch Program and if the viewer is already open the TP shows up in it, doesn't really start another viewer.

Firefox also asks to launch an external program for me too, although it's worded very differently.

leyna
Posts: 135
Registered: ‎05-22-2011

Re: Chrome and SLurls

Reply to leyna - view message

OMG!  You're right!   How funny I never clicked for it to launch.  Well that's gonna be a big time saver.  Thanks so much!  

Jarnz Dench
Posts: 110
Topics: 1
Registered: ‎04-01-2009

Re: Chrome and SLurls

Reply to leyna - view message

I was the same too LOL, never clicked it knowing a second open viewer crashes my computer, until I did it by accident one day and slapped myself for all that wasted time 

Claireschen Hesten
Posts: 1,852
Registered: ‎06-24-2009

Re: Chrome and SLurls

Reply to leyna - view message

leyna thats standard behaviour for chrome even if you have LL's V2 viewer open and the external protocol request wants to open up Phoenix or Imprudence viewer etc (if you have another viewer installed) it will bring up the slurl in V2 and not open up the viewer in the external protocol request unless you have no viewer open

Qie Niangao
Posts: 4,847
Registered: ‎02-25-2009

Re: Chrome and SLurls

Reply to Jarnz Dench - view message

I'm having the same problem getting secondlife:// to launch from Chrome.  I'm guessing the answers here were for Windows because they seem pretty irrelevant to what I'm seeing in Linux.  What happens is that Chrome tries to run

xdg-open secondlife://regionName/128/128/0

which of course does nothing because the secondlife:// mime type isn't registered anywhere, even after running the (extremely brain-damaged) install shell script.

I'm not using any ~/.local/share/applications/defaults.list, and /usr/share/applications/defaults.list has nothing relevant, but it's sure not obvious to me what should go in there.  I'm hoping somebody has already learned the xdg-mime magic, since I've already spent much more time trying to figure this out than I'll ever save by not cutting-and-pasting the URI into chat history.

Honored Resident
Donna Saenz
Posts: 3

Re: Chrome and SLurls

Reply to Qie Niangao - view message

I get it to work with Firestorm on 64bit Linux Mint 15  Cinnamon. I think the same principles apply to other viewers and version of Linux using GNOME/xdg-open.

Here are the steps:

1.Verify your protocol registration

Firestorm script should have done this for you when you run firestorm script which in turn launch etc/register_secondlifeprotocol.sh to set things up.

Can check by:

$ gconftool-2 -R /desktop/gnome/url-handlers/secondlife

command = /opt/fs-latest/etc/handle_secondlifeprotocol.sh "%s"

enabled = true

Make sure the path for the command is correct.

 

 

2. With Firestorm is running, run:

etc/handle_secondlifeprotocol.sh secondlife://someplace/1/1/1

The "Place Profile" popup should appear every time you run the script with different slurl

 

3. Under ~/.local/share/applications:

cat mimeapps.list

[Default Applications]

x-scheme-handler/http=google-chrome.desktop

x-scheme-handler/https=google-chrome.desktop

x-scheme-handler/mailto=thunderbird.desktop

x-scheme-handler/secondlife=firestorm-viewer.desktop

text/calendar=gedit.desktop

audio/x-vorbis+ogg=totem.desktop

video/x-ogm+ogg=totem.desktop

image/jpeg=eog.desktop

text/html=google-chrome.desktop

x-scheme-handler/about=google-chrome.desktop

x-scheme-handler/unknown=google-chrome.desktop

 

[Added Associations]

 

Make sure you have the entry added in bold above. With this added, Chrome browser should launch Firestorm every time you click an SLURL.  Two problems, we only want this to launch once, and we want the SLURL to be passed to protocol handler.

 

4. Under ~/.local/share/applications:

 

$ cat firestorm-viewer.desktop

[Desktop Entry]

Name=Firestorm Viewer

Comment=Client for accessing 3D virtual words

Exec=/opt/fs-latest/etc/handle_secondlifeprotocol.sh %u

Icon=/opt/fs-latest/etc/../firestorm_icon.png

Terminal=false

Type=Application

Categories=Application;Internet;Network;

StartupNotify=true

X-Desktop-File-Install-Version=3.0

StartupWMClass=do-not-directly-run-firestorm-bin



Replace the command with protocol handler.




5. I am unsure if other scripts will overwritten the above setup … but it works under Linux Mint 15 Cinnamon .  I know Linux Mint 15 KDE just works without this horrible hack!!

 

If you know of a better way to do this, please post.