Reply
Honored Resident
warehousefifteendesigns
Posts: 62
0 Kudos

Dae parsing issue

[ Edited ]

I've read the forums on posts about this already, and nothing has helped. I haven't changed my meshing methods at all, or my collada exporter. I can upload meshes fine, but I have tried this one mesh -several- times but to no avail. Dae parsing error still.

I can't bring up the log, because I'm on OS X, and I can only find instructions on locating them on windows. But I have been having a lot of problems with the exporter over the past few days... a lot of errors stating cannot create inventory asset. I haven't changed a thing, things just seem to have broken. Any help would be appreciated.

I have exported the dae files back into 3DS Max, and they look fine. I don't export textures with my meshes, I apply then in-world after. I have less than 8 groups.

 

Many thanks in advance.

Owner & Founder of Apple Fall, fine interiors, homes and furniture for Second Life. 100% Mesh.
Honored Resident
warehousefifteendesigns
Posts: 62
0 Kudos

Re: Dae parsing issue

Reply to warehousefifteendesigns - view message

Okay I'll update this myself. Don't know what I did, but 17 tries later, I got my mesh into Second Life. I unchecked 'single matrix' in the dae exporter, and I think that's what it was. It has always been checked, and never thrown a problem. But unchecking that worked. For future reference for anyone else.

I know things are tempremental, but who knows. :/

Owner & Founder of Apple Fall, fine interiors, homes and furniture for Second Life. 100% Mesh.
Advisor
Kwakkelde Kwak
Posts: 2,376
0 Kudos

Re: Dae parsing issue

Reply to warehousefifteendesigns - view message

Glad you got it fixed...for what it's worth the logfile should be here:

/Users/[YOUR USERNAME]/Library/Application Support/SecondLife/logs

"The superior man understands what is right; the inferior man understands what will sell."
Confucius

Honored Resident
warehousefifteendesigns
Posts: 62
0 Kudos

Re: Dae parsing issue

Reply to warehousefifteendesigns - view message

Thank you very much. :smileyhappy: Relatively new to Mac so don't know where these things are.

Owner & Founder of Apple Fall, fine interiors, homes and furniture for Second Life. 100% Mesh.
Medhue Simoni
Posts: 3,854
Topics: 94
Kudos: 131
Registered: ‎02-25-2009

Re: Dae parsing issue

Reply to warehousefifteendesigns - view message

If you ask me, all the unloaders are temper mental. It like an exercize now to upload any mesh, let alone a rigged 1. I've uploaded a rigged mesh hundreds of times. Now, with a new default set up I'm using, I can't get anything created off it to upload.

Honored Resident
Xenos Xenga
Posts: 14
0 Kudos

Re: Dae parsing issue

[ Edited ]

Reply to warehousefifteendesigns - view message

Hi, I'm on OS X too. I made a fairly simple structure which uploaded flawlessly to SL. Next I mirrored the structure by scaling it with negative values. Trying to upload was impossible, with error message: DAE parsing error.

I used your trick and unchecked the "singel matrix". Next, lo and behold :smileywink: it uploaded, but alas, it was no longer mirrored, although is was in the 3d application.

I ended up, having to make a new mirrored version, without resorting to negative scaling. I will experiment a bit with these issues and see. Will keep you posted, cheers, Xenos

Honored Resident
Tomos Halsey
Posts: 34
0 Kudos

Re: Dae parsing issue

Reply to warehousefifteendesigns - view message

Unchecking single matrix fixed it for me too even though i've had it checked for every mesh model in the past. I think it has something to do with the mirror tool. Someone else reported it failing after they mirrored something using the tool and not the modifier. I have also had issues in the past with games like Quake 3 Arena and Unreal Tournament with using the mirror tool and having it break the export.